Download

Luoshuang's GPULightmass

Have you tried to clean your lightmass cache?
I had the same issue, clearing my cache fixed it.

Silly question - how do you clear cache ?

Run swarm so that the swarmagent process is running, if it isn’t already.
Open it’s window by doubleclicking it’s icon ( orange/black icon. )
Then Cache -> Clear.

That’s also where you can set up stuff like networked rendering and etc.

I was getting the same error, I tracked it down too certain assets that crashed the gpu lightmass, The only thing i could see different about these assets is they had many materials approx 11 and 12 each, and 4 lods.

As a test I duplicated the rest of the scene and it Rendered correctly, so didn’t appear to be hitting the memory limit. I’m working on a very large citscape 6x6 km.

PS if your GPU light mass is hanging on “Importing surface cache”, it could be an asset with corrupted lightmap uv’s,

*Edit, my reply above dosn’t seem to be working anymore, the troublesome assets that I removed don’t seem to be the sole cause.

It now seems to be having problems with a masked material that im using for foliage, i set it to opaque and i don’t get the error, it seems very random though as these assets were rendering previously,

To further confuse myself, I opened a separate scene to test the foliage as masked and it renders, Then re-opened my original scene and I no longer get the crash?

*Edit number 2
Ok i seem to be getting consistent renders not crashing without any fluffing around, I have a landscape in the scene with the static lightmap resolution set high, Ive halved it too 8 from 16 and it seems to be more stable, Not sure if there were simply to many high res light maps being requested. The res is a little low, ill might fiddle with the terrain res, so more lightmaps, but lower res as opposed to less lightmaps but higher res.

My actor and poly count is low, approx 200 actors, 6mill polys, but tons of lightmaps from the terrain sections.

I was about to download the lightmass for UE4 and found there is extreme version there.Is there any difference between Ultra high quality and Extreme lightmass for UE4 4.20?

i have 4.20.2 and my GPU is gtx 1050 Ti so that means i can’t install Gpu lightmass ? bcoz you said from 4.20.1 it requires nvidia Version >= 398.26 ! but i have 391.35 and its says your drivers are already up to date

Hi there,
I am testing GPU lightmass baking with this classic simple scene and getting some strange issue. On the bottom the areas behind the wall was baked corretly (dark behind the wall and bright front of the opening), but on the ceiling the part behind the wall is actually brighter than part in front of the opening ???

Lighting is BP_LightStudio with different HDRI maps, same problem.

Here are some screenshots.

Looks like Lightmap bleeding to me. What’s the lightmap resolution? And can you show the mapping? (Open Asset Editor of the Mesh and then on the top bar look for UV#2)

Or maybe you didn’t remove the top and bottom face of this wall?

Liightmap resolution for walls are 256 and for ceiling 2048, same as for the floor too.

https://forums.unrealengine.com/development-discussion/architectural-and-design-visualization/60547-lets-make-lightmass-epic-and-understandable?p=1460932#post1460932

Here you will find the download link of this scene. Could you please bake it and post it here, just want to compare.

Becareful about the ‘two sided emulation’ behavior of GPULightmass - IIRC the materials in this scene are mostly two sided?

@Situx first you are the best, thanks a lot for this script :smiley:

but when i launch the script, config download 4.20.1 and not 4.20.2 version

Awesome it helps someone else!

V0.3 is out, and supports 4.20.2
You can clone the repo as it is now 2 files. Or just download (save as) the following files directly to any folder.
https://raw.githubusercontent.com/sgeraldes/LightmassConfiguration/master/LightmassConfiguration.bat
https://raw.githubusercontent.com/sgeraldes/LightmassConfiguration/master/hash.txt

Let me know how it goes!

hi all
again my problem with hdri skylight in gpu lightmass 4.20.2 exterme

Unlike last time, this time I would say it is just that sharp. It comes from the sun-disk in the cubemap. I’ve done comparison with VRay (see #437](Luoshuang's GPULightmass - #457 by Luoshuang - Rendering - Unreal Engine Forums)) and it produced the same sharp shadow. CPU Lightmass isn’t a good reference - for this case you need to set a 0.01 Indirect Lighting Scale or set bAllowIrradianceCaching=False in BaseLightmass.ini to compare (no doubt this will be very slow). If you still have some problem, you can upload the cubemap and I’ll test it in VRay.

've uploaded a new 4.20.2 version which allows you to set GPULightmass quality settings directly in BaseLightmass.ini without swapping between different versions. Scroll down to the end of BaseLightmass.ini and find DevOptions.GPULightmass. A better way is to create a DefaultLightmass.ini under your project’s Config folder which only contains the DevOptions.GPULightmass section so that you can have per-project settings.

Note: GPULightmass still ignores legacy Lightmass quality level, because while therotically I can make them connected, that may be very confusing.

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_146463_1535848088000_185”}[/ATTACH]

As a comparison, the parameters for the presets are:

FastPreview:
NumPrimaryGISamples=16
NumSecondaryGISamples=8

MediumQuality:
NumPrimaryGISamples=32
NumSecondaryGISamples=16

UltraHigh:
NumPrimaryGISamples=64
NumSecondaryGISamples=16

Extreme:
NumPrimaryGISamples=128
NumSecondaryGISamples=32

Your rendering time is roughly propotional to the square of these numbers. Power of 2 is recommended. Also do not set the numbers too low or too high as that may cause strage problems (completely black, artifacts, or crash and TDR). Especially when you tune up NumSecondaryGISamples you will want to increase TDR.

Shadows on surfaces that make a very wide angle with the rays emitted by light source cause that kind of “artefacts” you can see on the image at the outside part of the chair backrest.
( in this scene light goes from spot light directly form the ceiling /downlight/ ). Is this a bug or sth ?

Used Lightmass: GPU 4.20.2. Same effect at Medium or Extreme.

Would you like to upload a small scene reproducing this problem so that I can look into it?

thank you! this is an amazing day for me discovering this.

btw does the light mass calculation uses the ram or Vram?
in default unreal i had to keep the sum resolution of my static meshes below my Ram limit.
i have 16 gb Ram and 8gb Vram, is the limit 16 or 8 gb?

Thank you again. wonderful thing for UE

Amazing!
Do we need to restart Unreal for changes to take effect, or can they be done on-the-fly?
Any other changes we should be aware of?

i just made a test,
you can change the baselight.ini on the fly, no need to restart.
which is awesome