Luoshuang's GPULightmass

@Luoshuang: Is it still possible to bake lighting on my single 750Ti gpu (2GB) without running out of VRAM? Or would upgrading my gpu be more beneficial?

Just FYI, it doesn’t work. Yes you can select which cards to use CUDA with, (they are all select by default). But GPU Lightmass will only use one.

Your quote and reply are confusing.

He was answering the question: “If I have multiple GPUs on my machine, is it possible to select which one does the baking? (E.g. to use the non-display GPU for baking)” and YES, it is possible to select which single one does the baking with either technique, and it DOES work. He always said that multi-GPU does not work.

Probably not. I tried baking super simple scenes with a 750 TI and was not able to. It runs out of memory always. May be something else is the culprit? or just maybe just 2GB doesn’t even cut the most simple bake?

I had no issues with a 970 (4GB), or a 1050 TI (4GB), and of course no issues with 1080 TI.

I get this error even on very simple scenes. This one has only 10 lightmaps. Something seems very wrong with the memory being “allocated”?

This is with a custom build of 4.20.2. I followed the instructions here but maybe I did something wrong: https://forums.unrealengine.com/deve…65#post1460865

Do I need to rebuild the entire engine? I only tried rebuilding UnrealLightMass.

[Edit] FYI, I have 16GB of system RAM and a GTX 1080 Ti, so I don’t think it’s a hardware issue. The message pops up while it says “Building lighting…”, but I haven’t seen the GPU-specific progress bar at all.

​​​​​​​Hmm…this problem for me seems to happen on gpu lightmass 4.19+ on Windows 10. But gpu lightmass runs completely fine on versions before 4.19, on Windows 7, and without modifying the tdrdelay, this is with my 750ti…so I don’t think my gpu card is the problem.

I wonder where you found versions of GPU lightmass for anything prior to UE 4.19.

Hello!! @Luoshuang ** Are the emissive materials working on 4.20.2? I’ve tried to light some areas by using the emissive but it´s not working.**

Pd: I’ve ticked the “use emissive for static lighting” option.

me too but seems not working

Should be fixed in 4.20.2 unified settings now. It is caused by firefly clamping introduced in 4.20.

settingswithfirefly.png

Now firefly clamping threshold is exposed through ini. This technique aims at removing fireflies by making your image biased (darker). Threortically speaking it should be set to the maximum brightness in your scene. In practice you can set it to a high initial value, then keep lowering it if any firefly is seen.

Hi @Luoshuang !

It would be awesome if it could support a multi gpu on same computer, any plans for that?

> It would be great if you could bake the lightmass of only the selected item. So that I don’t have to recalculate everything.

I strongly agree, current workflow requires to recalculate everything. It would be very handy if we could do following

  • baking lightmaps for selected objects
  • tweaking parameters for GPUlightmass

Hi Luoshuang! Really awesome work but I have report that the build does not work with landscapes, at least big ones

EDIT: ok, one should not choose landscape LOD 2 (or higher) for lighting. The missing nvcuda.dll error etc. come from that

The Unified Settings version does not work with source builds. Only the “regular” version work. When building light with a source build and the unified settings version, light build fails and I get this error message in the message log:
https://i.imgur.com/J6DRFgL.png

Furthermore, the emissive lights don’t work with regular 4.20.2 GPU Lightmass, it’s my understanding that this is only fixed with the Unified Settings version, which is broken for source builds.

EDIT: Just to clarify, the regular 4.20.2 version does work with source builds, the unified version definitely doesn’t, thus I can’t get emissive lighting to work.

I’m facing this bug. When using darker materials it start to appear these kind of splotches.

Luoshuang,

Were there any changes from 4.19.1 to 4.20.2 in regards to a Titan V card?.

On a project i’m working i can do the lighting fine in 4.19.1 but not in 4.20.2

When switching to 4.20.2 the computers freezes once the GPU Lightmass Progress says Radiosity pass 30/30 , I have to reset the computer. It never gets to the Overall texel progress.

Thanks, that explains my issue too! (Getting the same error)

Hello Luoshuang. Thanks for the fix!

Now the emmisive lights are working!

But i’ve found an issue with the quality of that lights. I’ve attached some images that explain the issue.

Left: 4.19 Right: 4.20.2

Thanks!

Did a bit more testing.

All test done on the same computer.

Dell Precision Tower 7810
Dual Xeon E5-2650 2.3
128ram
Win 7 pro 64
Tried several drivers from 39.31 to 399.24 on all configurations.

Unreal 4.19.1
Nvidia 1080, 8GB
Workes fine

Unreal 4.20.2
Nvidia 1080, 8GB
Workes fine

Unreal 4.19.1
Nvidia Titan V, 12GB
Workes fine

Unreal 4.20.2
Nvidia Titan V, 12GB
Computer Freezes, Needs to restart windows.

Attached is a screen capture when it crashes.
As soon as the last radiosity pass finishes it freezes. So i assume there is some issue with 4.20.2 and the titan V.

Any one else having the same problem?

hey guys area lights(rect lights) supported for 4.20 in gpu lightmass?

lighting seems diffirent cpu vs gpu… using 4.20.2 stux script medium. “use emissive for static lighting” disabled