Luoshuang's GPULightmass

I am getting the same error, but thank you for at least building this version. Any suggested solutions?

@maxbrown @PMcKenzie2004 Updated, you can try again

cuda.jpg@Luoshuang Wonderful! Tried and alas -still something that stops the process just after Building BVH 100%
Edit: using a gtx1080 & 388.59 driver

This version uses CUDA runtime version v9.2.148 which requires >= 398.26. Maybe you need to update your video driver? I’m on 398.82 now.

Thank you so so much! <3

@Luoshuang updating to the latest driver fixed it. Crossing fingers the Oculus plays nice with this new driver…
Thanks a lot for updating the plugin to 4.20! :slight_smile:

@Luoshuang Thanks for creating the baker for 4.20.1. Any chance for that ‘‘smoothing’’ solver? Maybe we can tweak it to get soft lighting shadows?

Looks like some of my experimental code accidentally went into the 4.20 version…

@Makigirl 's HDRI SkyLight shadows testing scne:

Skylight resolution is vastly increased and there is experimental ‘explicit skylight sampling’, as a result the shadows will be even sharper - not very sure whether you guys are gonna like this…

Thanks, I’ll try again today and report back. EDIT: Works like a charm.

gpu_success_2.jpg

Maaannnnnnn… @Luoshuang you are great… Thank you very much for spending your precious time to develope all of these.

@Luoshuang Can I ask if anything is changed regarding IES pointlights? It seems like they are completely blown out compared to the 4.19 GPU-LM plugin.

There shouldnt be changes about them. IES has never been supported by GPULightmass. Maybe it is a change between 4.19 and 4.20.

@Luoshuang - Do you have a paypal.me link? I would love to encourage all the people who are using your plugin to donate something they can afford to keep you happy and to honour your hard work. What do you guys think?

Rock solid for the 3 hours this took (1080ti). Extreme settings.
EDIT: Using mostly spot lights gets similar quality but is now at 53 minutes! I am using the default lightmap resolutions that Datasmith produces.

Oh thanks God Luoshuang is back.,

Agree we should pay back for extreme effort of Loushuang,

HI all,
I have a problem with my scene when i bake(4.19 or 4.20)
it’s a new problem for me, because 2 days ago i didnt have this problem.
i did just add lot of assets (230 assets) into my scene, and now ue4 doesnt bake, when i remove some assets, baking works
I have 3600 asset/actors into my scene(cut by level)
any help is appreciate :slight_smile:

1080TI - 48Go ram

@fly06bzh - have you tried cleaning and revalidating the swarm cache?

I got a question. What is the approach for foliage and tree’s leaves? On GPU the leaves’ shadows are completely static, while on CPU you can see them moving. Is there any workaround for that or is just a limitation for now?

Hello everybody…

My problem is, after I started bake my scene with 4.20.1 GPU, skylight does not affect the upper floor of the apartment. When I change the intensity the lower floor takes all the light effect immidiately. I can see the reflection on the floor is changing. But there is completely no such effect on the upper floor. It is very interesting…