Download

Luoshuang's GPULightmass

What was it? Im getting that in one of my scenes too.

people. ue4 has native gpu baker. you don’t need this “mod” anymore.

Install script updated for 4.24.3, 4.25.4, and 4.26.2

Releases · sgeraldes/LightmassConfiguration (github.com)

You can use the script to change quality settings on the fly, no need to restart UE4 or mess with ini files.

If you use it, and want to support the work to keep it up to date, please drop by my patreon:

3 Likes

Can you Please update it for 4.26.1 ?
I’m using an old GPU and if you update it, I will be very Glad.

Updated to 4.26.2. It was also updated to fix some minor bugs and remove unused code.

The latest version has a few different files to backup than previous versions, so make sure you re-create your backup (option 1). If you currently have GPU lightmass installed without the script, I encourage to do a “UE4 validation” to restore CPU lightmass before using the Installer, so it can take a clean backup.

the native one has inferior quality as I have posted here earlier.

1 Like

so how do i install this? first post of author doesnt say anything

Just follow the link

1 Like

how did solve this i still have this error too

Hello Guyz im Having those 2 Problems ( i use for Version 4.26 )

Error Message Nu.1 :-
Assertion failed: primitiveCount > 0, file C:\UE4\GPULM-src\GPULightmass\GPULightmassKernel\BVH\EmbreeBVHBuilder.cpp, line 61

Error Message Nu.2 :-

So how to fix those Problems Please, i have been trying to fix these errors for more than 5 days of no hope :frowning:

For me, usually that problem is due to some problematic mesh.

You can try to delete a 25% of all your scene meshes (always without saving, of course). If persists, another 25%, etc. Until you can isolate the ‘corrupted’ mesh.

How can it be Corrupted !!?, it has all lightmaps channels assigned Correctly

Someone Answer please

hi!
I’m currently using Unreal Engine 4.26 and when I bake, I’m experiencing the following image. This phenomenon happens unconditionally when more than one light is used. Is there a solution?

1 Like

Hey Shaft, how is it going?
It is an installation error.
Revert to UE4 original CPU install. Once you have the engine back to manufacturing setting. In C:\Program Files\Epic Games\UE4.26, drag Luosang’s Engine folder. Hit Replace files and you are set!

1 Like


I have the same issue with the shadow, did you find the solution for that ? Thank you!

1 Like

I’m using UE4.25.4, and I ran out of RAM when building lighting with this MOD. I currently have 32G, and my map has about 450k grass and trees. Is this normal, and how much RAM do I need to make it work?

Probably you got out of VRAM (GPU’s RAM). But don’t intented to build 450000 trees, even with a NASA computer.

Try to start ‘cuting’ your scene and making a new build, until you get rid of error, and find your limit.

Hallo, will we be getting the 4.27 gpu lightmass anytime soon?

Is possible Luoshuang’s lightmass 4.26.4 works with Unreal 5?
I need to bake lightmaps on certain situations with Unreal 5 and default GPU lightmass ins’t working.

Hi there. I’ve been using my GTX 1070 for quite a long time with this compilation of GPU Lightmass on UE 4.25.4 and it was working perfectly. Yesterday I changed the thermal paste of my 1070 processor (that’s all I did). Once I put it back to work, the GPU Lightmass in the editor gives me the message “No Cuda capable device is detected”. I left nothing without trying: driver update, unisntall, install again, made a couple of Verify to the engine version and copied the GPU Lightmass Engine content again, 4.25.4,ect ect ect. Nothing changes. Can’t use the GPU Lightmass anymore now. Same hardware. This is strange. Same message “no cuda capable device is detected”.