Download

LUMEN, why inside a closed room I can even see lighting instead that darkness?

I’ve create a room with 4 walls , floor and ceiling, room is completely closed but I still see lighting, why?

3 Likes

any suggestion?

1 Like

I have the same problem but only if I have two closed rooms that are connected through a doorway and I look inside the other room.
Sorry that I couldn’t help directly.

Thin walls+Distancefields dont play well together

I had a similar problem and it turned out my floor was too large (it was a huge rescaled cube) and wasn’t being added to the global distance field, so there was a huge hole in the ground where light was coming in.

You should also ensure that if you are using exponential height fog, that you have enabled volumetric fog, as fog cannot be shadowed unless it is volumetric.

With Lumen you should not use a simple plane (even with 2-sided mat) or box with tiny width (less then ~10 cm) as a walls cos this will lead to light leaking

Left wall from cube with enough width:

Left wall from cube with tiny width:

Left wall from plane with 2-sided mat:

2 Likes

Correct.

I’m using cubes with right thickness but the problem is stills on

Volumetric fog is on and not shadowed. Sure this may affec lighting inside a cube? I’m working on Skylight, postprocess and directlight but nothing

Do you have a “Generate mesh distance fields” option enabled in Project settings? Lumen relies on this one heavily.
Also you can go to Show → Visualize → Lumen Scene to confirm that there are anything for Lumen to work with

Yes I double check everything, both Lumen and distance field.
The problem disappears if I turn OFF the skylight but, it doesn’t make any sense. So there is a bad relationship between skylight and lumen but it shouldn’t be!

Having the same problem and I’m in the middle of a building. There is a lot of geometry around. Distance field settings and Lumen settings should be okay. I tried lighting everything with an emissive dome and that works just fine. It’s the skylight not being blocked that’s causing the problem. Using the sun sky actor for my scene. I think with Lumen we could finally get “real” HDRI like lighting but the way the skylight works is causing a lot of problems for me.

Basically I’ve seen the SKylight is what is causing me the problem. For some reason skylight is not able to recognize a closed environment and I have the same skylight outdoor and indoor.
If I remove skylight, despite Lumen is on I see that the dark area and shadows are really dark, so despite Lumen on I cant remove skylight.
So how can I fix it please?

I also need help. Tried everything I could think of and did a lot of research on this. At this point I am not sure if its the fake skylight reflection causing the issue or the lighting not being blocked. I guess both.
It seems to work fine in the original Nanite / Lumen demo.

1 Like

Well, I see that yes , Skylight causes this issue even if set to 1.0 power. The problem is the skylight is important for exterior GI and i cant remove otherwise I have fake constract/shadow.
I dont know what to do!! I’ve beent rying everythings!!

Not a great solution but changing intensity scale to 0.1 in the skylight and changing min/max exposure to 0.1 greatly reduces how noticeable it is for me.

1 Like

hi, problem is that I need Skylight :frowning:

low resolution uv maps can casue this, either fix the uvs or change the light to be dynamic.

Out of curiosity, why?

Why do you need the skylight for an interior?