Lights set to Static produce no light after building lighting

When I build lighting, it builds instantly and everything is black. It doesn’t seem to matter how many static lights I place.

Hi BlackRang,

There isn’t enough information here to proceed. I’ll need to know the following:

  • Does this happen only in your project, or a blank default level as well?
  • If this is your own project, make sure you’ve got a properly setup Lightmap UV and set lightmap resolution.
  • Do other lights like stationary and movable show up in your level?
  • Is this on a Windows, Linux, or Mac machine?

Thank you!


Using Windows 10 64-bit with fresh download of source from Github.

Using a blank project causes lighting to build correctly.

Copying the config folder from the blank project to my project does not fix the problem.

Copying my content, source, and plugins folders into the blank project does not stop lighting from building on the blank projects default map, but lighting still does not build on my map.

Swarm never opens when building my map.
Map is primarily marketplace assets.

I’ve noticed that lights default to stationary instead of static when placed in the level, even when I first made the blank project. I don’t know if this is new, but it seems very strange to me.

I made a new blank map. I opened my map, highlighted everything in the world outliner and copied with ctr+c. I pasted it into the new map with ctrl+v and lighting builds fine in the new, but seemingly identical map.

Lights have always defaulted to Stationary when placed in the level. This is a middle ground option to give dynamic lighting for movable actors and baked lighting for those that are static.

If you’re only able to reproduce it in this map and it’s not reproducible I’m not sure. When something like this happens here are some steps to help you in the future:

  • Test in a new level to see if lighting is building for the project.
  • If lighting is building, then in your original level where it’s an issue, open up Swarm Agent and check the log and status tabs. You can follow tips on my Swarm Agent Guide here.
  • If lighting isn’t building, make sure that Swarm Agent is opening and kicking off the build. With marketplace assets, sometimes they set the lightmap resolutions super high!! This can cause lighting builds to take too long, or to run out of memory on your machine. High Resolutions + # of Actors + map size can all factor into this.
  • If lighitng isn’t building after checking the marketplace assets, it’s best to save a copy of the map and start going through the world outliner to remove Actors until you find the point where it is working.

Sometimes there isn’t a straight forward answer and it will require some work to troubleshoot and track down what could potentially be causing the issue.

Hey there!

I have the same problem with my scene. All the stationary lights are baking fine, but static do not at all. I’ve read all threads about lighting issues and their solutions on Unreal’s Answers but none of them helped yet.

  • My scene is originally created with 4.12.5 version (but I tried to open it on 4.14.3 and same problem happen)
  • Machine: i5-2500K / GTX 970 / 32GB RAM / Windows 7 System
  • All the lightmap stuff like resolutions, UV’s etc are properly set.
  • Tried to bake static point lights on a new blank level with some BSPs and it WORKED.

The only warning I get after bake is:
“SkySphereBlueprint Collision enabled but StaticMesh (SM_SkySphere) has no simple or complex collision.”

Would be super-grateful for any suggestions,
Thank you.