Lights bleed when not casting shadow

Well i dont see any problem here. If you disable cast shadows the light will affect every surface that faces it as far as the attenuation goes, since you tell the light that there isn’t anything to obstruct it. If you want to use dynamic lights as area lights you just need to be more careful with the attenuation radius.

All of my lights bleed through the edges if I turn off “Cast Shadows”. They bleed as far as the attenuation radius and I can also see their reflections.

You can see this in the picture. Behind this room, there is another one(they are all part of same static mesh). I also added a thin wall in between them(wall from starter content) but even adding that changed nothing. Tried other solutions that I could find on this problem(light map res, double sided materials, checking for small gaps) but nothing helped.

Everything works just fine with enabled shadow casting, no bleeding at all.

Problem persists both on point and spot lights.

Thanks for the answer. Guess I should have read about some of the engines nuances before assuming that something is wrong.