Lightmap UV

Hello guys, I’m absolutely new here and I know this is a vexing issue and actually I did not plan to post here either. However, it is not entirely without. Unfortunately, English is not my mother tongue, and so I can googled after studying the forum contributions, not all questions. It’s about Archviz. I would like to keep it brief.
1- the power of two .: When I select a resolution of 128x128 in blender or other programs. I can then double the LM Resolution in UE4 as often, or only ever once. So 128 means min 128 max 256, etc. So if I know that I will need 512 in UE4, then I have to make min 256 in blender or 3ds max?
2-These paddings 2-4 Pix, I leave somewhere that all paddings together should be about 15%. Depending on the resolution, however, this would vary extremely. With a resolution of 16x16, this can be 50%, with a resolution of 512x512 much less.
3- You can see so different and contradictory things in the corresponding videos of the approach. Some of them strongly adhere to the aspect ratio of the Faces, the others do not at all. I have massive stretching proplems after lightmapping in blender. This stretching causes corresponding artifacts. Someone wrote that stretching at LM did not cause any problems, that I could see the opposite.
4- How is it possible to use the 0-1 uv space optimal, to keep the paddings, to apply the snap to pixeltools, and then to keep the same texeldichte on different walls without stretching or scaling, which leads to the 0 -1 uv space.
5- At the edge still a question. The Texeldichte preview in UE4 shows me only then “positive colors” like blue or green, if my maps for the walls of my apartment are much too small, un pixelated light (directional light) represents.

My specs
Dell Precision M6700, Quadro K400M, 3740 QM, 16GB RAM, Win 10,

Thank you very much for your effort.

GPU rendered textures must be in power of 2 demensions, although they don’t have to be square. I assume that when you talk about selecting resolution in blender you mean for packing, unless you’re making procedural textures in blender. If it’s just for packing then you’re not actually setting the texture resolution, you’re telling the algorithm what size your texture will be so that it can calculate appropriate padding. When laying out the Uvs you should use the same dimensions as your texture will be. Light maps in general are very small (64x64 is common).

You want as little padding as possible without having bleeding at lower mipmap sizes. There is no hard and fast rule for this. Because lightmaps deal with so much contrast they tend to have extra padding.

As a rule of thumb, you want the faces to not be stretched. Lightmaps are more forgiving because they’re Grey scale but too much stretching will still cause issues.

Each program has different tools for unwrapping. Some are better than others and there are often third party plug-ins to improve work flow. In order to give you a better answer here I’m going to need to know what you’re modeling and what your program is.

I don’t entirely understand the last question but it sounds like your texel density is off. If the density is too high then youre wasting processing power on details that can’t be seen and if it’s too low then things look grainy. Ideally texel density should be 1:1, texture:screen resolution. This is impossible to have in all situations however so just try to keep it close to the middle. If the texel density is too high then use a smaller texture for that object and if it’s too low then use a bigger texture, tile your texture, or use multiple textures. The best way will depend on your situation.

Hello Nuclear Arbitor,
many thanks for your response. I understand the answers nciht. Neither in the English nor in the translation. I could understand because of the translation of google not everything. I’ve been using blender for many years. By choosing the resolution I mean the texture for the unwrapping, exactly. In blender I can specify the target resolution, but have only individual pixels with color uv grid. I have modeled an apartment with the walls, and have already achieved very nice results. However, I have the same problems as many other users with light that seems to shine and dyed meshes. This, however, must be masked with the experience gained with time.

Procedure for lightmapping the walls in blender

1-I open the UV editor in blender
2-I add + texture (no image)
3-I now have the option to choose the resolution. for example 64x64,
and a “texture” blanc, uv grid. Every grid has 32x32 pixel and color grid.
This I do first with the first uv channel for texture information, but with greater resolution for example 512x512.
then I add a second uv channel and make it as in the picture. Ctrl a + p for paddings and then snap to pixel. If I do this for the lightmaps then everything on all walls, I have different size ratios.

Since I can exceed the texture over uv space 0-1 ?, I can adjust all uv grids of the size. Thus, all the textures that i i ue4 order in the right proportion.
I have a few pictures for illustration. Partially, I have also quite good results in ue4 for the beginning. I have to prepare myself bit by bit.

What do you mean with the same dimension?

When laying out the Uvs you should use the same dimensions as your texture will be. Light maps in general are very small (64x64 is common).
alt text

here some more pictures

after you have all of the mesh unwrapped in the correct proportions you need to scale it down to fit within 0-1 UV space. if the UV islands are not at the same scale you can apply a grid texture to the object in blender and scale the island until the grid is the same size on the model.

if the model’s texture is 1024x1024 you should use 1024x1024 as the target resolution to get the most accurate snapping and smallest padding. light maps are usually very small though. UE4 uses 64x64 as the default. this makes the pixels relatively large and requires lots of padding to prevent bleed. light maps are particularly sensitive to bleed.

if you unwrap the model so that nothing is overlapping or stretched and everything is in the 0-1 UV space then you can have UE4 make light map UVs based upon the work you did. this does add an additional UV channel but it should be ok. i don’t know which channel UE4 uses to generate UVs as i don’t see any option. it’s probably either the first or last channel. last would be more controllable.

let me know if you want me to reword anything. i tried to keep it as simple as possible to make translation more accurate.

Thank you very much for your efforts. If I make a texture already in blender on the object, so I should take for the LM the same resolution, or what do you mean with target resolution? What if I do the texture in UE4 myself like the walls? Which resolution for the uv grid should one choose? I’m doing two uv channels. If I do not have image texture for unwrapping, I still need to make a uv mapping.

What was also important to me: if I make an LM of, for example, 256x256 (in blender) which maximum resolution is possible in UE4 without the lightmaps to re-generate? With re-generate I mean under the static mesh editor - LOD - build settings? I import the fbx object and only under general settings I adjust the size. I have already had an object in blender with 64x64 resolution of the LM and under general settings the value set to 1024. Should this be done at all? That’s why I asked at the beginning, whether the resolution of, for example, blender can only be doubled once or several times?

I did not understand the first paragraph. But not for practice. what do you mean with correct proportion. If I put the lightmaps in blender in the uv reaum runterskalliere, they fill the uv space no longer. I can not scale in blender the entire uv space. In 3ds max, this uv space seems to be more abstract. In blender I must enter a resolution to generate this uv space. I’m talking about the LM all the time. I can not scale the grids on different objects without scaling within the specified uv space. That means, the uv space is not used optimally. Maybe I understand something wrong. I guess I do not understand something basic …

I’m trying to explain my problem again with the pictures. It is a very big work effort with adjusting the grids

1- mapping for LM on the largest object as reference. (You can not go beyond the 0-1 uv space)

2- try to map without texture. Grids do not end with scrolling, therefore unsuitable

3- I need to generate a uv space again, specifying the resolution and color grid, because you see the individual pixels or “lines”. The grids are visibly smaller than the first. Not so good with sun shadows on common objects I believe.

4 then I try to adjust the grids by scaling the entire layout. I could now estimate and choose a smaller map (resolution). That does not fold however with several different sizes.

Maybe I think too complicated. greetings

for absolute best practice if you’re doing a manual light map then yes, you should use a size like 64x64. UE4 generally does a very good job of creating lightmap unwraps though; i’ve only ever seen issues with lots of stacked overlaps. instead use the size the base colour and other maps will be. default lightmap size in ue4 is 64x64 though. that size is good for most objects.

can you upload one or all of the wall pieces? i think it might be easier for me to figure out what issues you’re having and how to solve them; particularly with the language barrier. i haven’t used blender much but i can download it later and take a stab. i do have both 3ds max and maya.

i will also try and upload some videos or images about unwrapping.

I have now all hours in blender with 64x64 unwrapt and in UE4 due to the reference lightmaps created new in 512x512. But it looks worse than before. Some cover up as if they were hovering. Light comes through dark corners. These lightmaps in UE4 are really an impertinence. For weeks I have been doing many hours in meticulous work these lightmaps in blender. the best results I had when I in blender from the beginning of a resolution of 512x512 voted. If you tell me how I upload the fbx file uploade I will upload it. Anything basic I misunderstand. The videos leave nothing. they are all in English, and everyone seems to be doing it differently. Watch 10 different videos and you will find at least 5 different approaches. The only one that makes good videos in german, builds the geometry in the UE4. Partially, I have good results, but I do not get some weaknesses away.

you should be able to put the .fbx file in a .zip file and attach that.

at this point, i’m not sure if it’s actually a lightmap issue or a baking issue. if it is a baking issue it’ll be harder to deal with because that has to do with the engine.

Hi, it’s not perfect yet. I have tried all the geometrical possibilities. In the room without windows I can reduce the light through the walls by turning off auto exposure. with a spotlight, however, there is something again. The lightmaps I could not arrange better. I’ve been trying it for too long text

i took a quick look at the UVs and there are some issues. i don’t know if those are causing your problems. i’ll clean them up tomorrow and try baking them.

Yes thank you. Take your time. Perhaps you say something about geometry. I have really tried all popular recommended variants. Consequently, I have also left blankets in the ceiling and the floor.

ok. i took a look and i noticed that all your models have tons of “ngons” or polygons with more than 4 sides. this is bad general practice for a lot of reasons. triangles are fine, everything is made of triangles. quads (a pair of triangles with the center edge hidden) are generally used for working because they produce good edge flow which makes life easier for the modeler.

now what i don’t know is if you were using quads and the export process screwed it up but from what i could see of the unwrapping it looks like you modeled it without them.

when i looked at the UV layout in 3ds max the outlines of the islands looked good but there were a lot of internal edges that were folded over each other. i would not be at all surprised if those folded polygons were causing issues, since those would be sharing UV space with other edges and are facing the wrong way.

i quickly cleaned up your floor mesh in a very crude way and gave it a basic unwrap in the first channel. on importing it into UE4 it generated better light maps then yours had because i cut the mesh up into squares.

your meshes also have open ends in a lot of places. while this isn’t awful, i would suggest you close those areas off. it won’t make a significant difference in performance and it will prevent light leaking. i would also cut your floor and ceiling into smaller pieces (break them at the doorways) for greater flexibility and better unwrapping.

floor is the triangulated mesh as i would send it to UE4. floor_quad is the mesh exported without triangulation to demonstrate rather bad edge flow.
[link text][2]

Thank you for your support. These are really some interesting news. On the ngons I did not respect. They probably come from the f-gon function in blender, with which I combine many faces into one. I thought that ue4 triangulated automatically, so I did not do it manually. In blender, quads to tris function.

now what i don’t know is if you were using quads and the export process screwed it up but from what i could see of the unwrapping it looks like you modeled it without them.

I dont understand this sentence.

If I split the ground, he came already after the import into ue4 multi-colored. One piece was darker, one brighter. This has not changed after the lightbuild.

your meshes also have open ends in a lot of places. while this isn’t awful, i would suggest you close those areas off

How exactly do you mean it? You have seen that my walls are very specifically modeled. Should I close the ends? How exactly should this look? It means that is not face to face. Where shall I close the walls? After the corners, in front of the corners. With me, everything goes together. Even the ceilings have recesses, because I’ve read, the edges are not areas to expand.

UE4 will triangulate automatically but you can’t guarantee it will do it well. the 3ds max fbx export options will allow me to triangulate a mesh on export. i always do this. it’s both good practice and necessary if doing normal map baking from a cage.

now what i don’t know is if you were using quads and the export process screwed it up but from what i could see of the unwrapping it looks like you modeled it without them.

what i was saying here is that i wasn’t sure how you were modeling your mesh. you answered that when you mentioned the f-gon function though.

the problem with the different shadows on the different parts is probably related to [this][1] (sorry, it’s in english). i suggest you use a threshold piece to hide the seam.

i did a basic mock up for you on the window piece. your original piece is on the left. this will help prevent light leaking through the wall (i don’t think this is a problem for you right now). having sealed meshes is also good practice.

Hi, Thanks again for your help. The with the hide of seams I read again and again, but do not know how the genmeint is. To sum it up once

1, no ngons, I think they come with me by the merger of several faces through the f-gon function.? The mesh should consist of quads? Some faces of my walls are u-shaping.

2, I can model closed walls up and down to the adjacent walls, I understood correctly? In some videos, the walls are closed up and kept open in others. A mesh (box brush) in ue4 is also closed, and there are no problems.

3, triangulate the scene before exporting. In the fbx settings there is unfortunately not in blender.

to get back to my initial question. if I in my 3d program a lightmap of 64x64 or in the ratio 1/64 attach, how high can be a lightmap in ue4 without it recalculate? I have always doubled the lightmap resolution under lightmap settings. or I must first under build settings the lightmap intermediate work. What would you suggest?

Many Thanks.

  1. correct. quads or triangles are fine.
  2. yes. closed is safer than open.
  3. if you’re not baking normal maps with cages then don’t worry about triangulating. there is a [triangulate modifier][1] in blender if you need it.

64x64 should be good.

i did recently find [this][2] though. according to it you should use 62x62 instead. i haven’t tried it yet so i don’t know how well it works.

here is a quick example i made in 3ds max of using a threshold to hide issues between the floor pieces.

Hello, excuse me, that I have not reported. I have to try the different possibilities. I think with the time one will find the suitable workflow for itself. There seems to be no specific plan to have the appropriate success. I get very good results, but I will probably need a lot of time. If I get my apartment until next year, I am satisfied. Best regards