Download

Lightmap trouble with curved objects

I’m working on a project you can see here :

But i have some trouble. I still don’t really understand how i’m supposed to setup lightmap. I’ll show you.

I use 3DsMax 2016 for modelling object. I know now how to unwrap object for texturing, and also i know for light map. Doing another unwrapping, setting it to another channel, and voila. I’ve followed tutorials about that before, but i allways get the same result.

But my wall have some curve. So i don’t know if i’m supposed to keep the curve, or make it rectangular.

Wall LightMap (64)
wall-lightmap01.JPG
wall-lightmap02.JPG
wall-lightmap03.JPG
wall-lightmap04.JPG

Lightmass Settings :
Static Lightning Level Scale : 0.1
Num Indirect Lightning Bounces : 5
Indirect Lightning Quality : 2.0
Indirect Lightning Smoothness : 0.6

The Ligthning isn’t final in my project. It’s supposed to be a moonbase, and only light come from the selling.

So the guideline where they say to align the UV’s to the pixel grid is useless the vast majority of the time, enough to where I would just ignore it because unless your object is rectangular then it doesn’t work.
In your case, you don’t need to split anything, the wall should be able to flatten out just fine. Those UV’s of those extruded details should almost look like it’s inset.

So, i’ve followed what you’ve said and simply flatten the UV. This is what i’ve done :

wall-lightmap07.JPG

Result
6106fb85a33979962c66678eeb3f3dee895600c2.jpeg
83a81364ec80778e2ad211855d1838104a96df3d.jpeg

You will also need to make sure you adjust your lightmap resolution. Also, it would be better if that was a single mesh for the wall rather than sections, you’ll get issues where the lighting is slightly different from one section to the other, and since they’re low-poly it doesn’t save much memory by using the copies and costs more in draw calls.

Also, those outside surfaces around the edges are a problem, since they don’t do anything and they will bleed onto the visible areas.

So i’ve deleted the faces on both side. So no bleeding. But i’ve cranked up the resolution to 128. And now i have something of a mess. So i’m still gonna try other settings.