Lightmap tiles on mesh...hmmm?

Hi there guys! I am a long-time lurker, but first time poster here. I have a lot of questions regarding the UE4 engine. I’ve been able to figure a lot out, but man, some stuff has me stumped! I’m really struggling to get this to work, and was hoping someone here could answer my question regarding light-maps and UE4.

So I have several objects in my scene, all UV Unwrapped, and most of them are set up to tile the texture.

I have another UV Map channel set up for the lighting to be baked onto for each mesh

Maybe the more experienced users here can already see the problem.

This is a photo of the model in the engine before baking lighting…


Okay! So…what is going on here? I’d really like to know?

Thank you!


I don’t know where to start… :smiley:
Your lightmap uvs are completely wrong!! You should break up the islands at least at the corners!! And place them separately covering as much space as possible!!
Your lightmap resolution should be at least 512 in the editor!
You should bake with some materila on!
I hope it’s a good start! :wink:

Good luck!

Hi there, in Blender, how do I seperate selected faces from another face in the UV editor?

I am on my phone at the moment…can’t access blender, but will try your suggestions when I get home. I knew that lightmap was wrong, but at the very least, I was expecting low resolution lightmap, not a tiled one! It seems to be taking the coordinates from the first UV channel.

Is there a way ti detach the lightmap without making new seams, and making my UV maps all over again? (A stitch/unstitch feature like in max would be handy. Thanks!)


Sorry I’m not a blender user but I’ve “heard” there are very good tutorials about the subject…
I guess there should be a “face mapping” option in the uv editor because this is the most basic one… selecting the faces and “flat map” them should break up your lightmap uvs… then you can scale and pack them…
Try to find a good tutorial will be better than my explanation! :wink:

That’s quite alright, but after some reconsideration, I don’t think this is a blender specific issue, though it could be.

My scene in blender consists of several unique objects, combined together to form the cottage/house/whatever. I’ve created separate UV’s for each of these objects, and have imported them into unreal as ONE model. I was hoping all of the channels for the objects would be kept, but it simply overlaps all of them into one combined channel. I will try renaming all of the channels to be unique, but I’m afraid unreal won’t use recognize separate light maps. Will I have to import all of my house “pieces” separate and piece them together in UE4? There must be a better way to do this.

I can auto generate, but the results are sub par because I think the lightmaps are too large for accurate results (512)…any assistance?


I don’t know what quality bake you’re after… if not high res archviz but a game it still can be good… you can keep your mesh one piece but you have to have a better lightmap!! With padding cover as much space of the map as possible!
…if you’re after high quality: you have to rethink your modelling and lightmapping…