Lighting takes a few moments to properly apply to a level on load

Hello,

I’m having an issue where it takes a moment for the lighting of a scene to apply when I first load it.
When I first load a level, the lighting looks like this.


Then, after a few seconds, it looks like this, which is what I want.

I do not believe this is an auto exposure issue, as I have disabled that and the issue occurs with or without it. I’m not sure what the issue is here, as I don’t have too much experience working with lighting.

Thank you.

Is it static lighting? It can take a couple of seconds to apply the lightmaps.

If this is the case, I don’t think it will happen when you package.

Thanks for the response. It is static lighting. I had initially hoped that the issue would not be present on packaging, but it is.

Hmmm. It might be that you have a lot of memory dedicated to the lightmaps. IE, they are too large.

A quick way to tell is to look at the size of the build data file for the level:

image

It really depends on a lot ( level size, type of hard drive etc ), but anything > 250 MB for a normal HDD and > 1.5GB for a SSD. Those are totally finger in the air figures…

The largest build data file I have is about 75 MB. To test this out, I made a new small map that just has 6 box brushes and a spot light. My lights use indirect lighting in my actual maps, but for this test I turned that off to see if it had any effect. I get the same issue in this small map, with a build data size of 153 KB.
Initial


After a few seconds

These screenshots are of the editor, but I get the same thing in the packaged version.

Ok, did you build everything? ( using the build button )

Yes I have. Are there any build settings I am overlooking that would cause this? I have seen this issue regardless of the lighting quality I select, so at the very least I don’t think it’s that.

I’m out of ideas, actually.

Have you tweaked the project settings much?

The only thing I think I’ve touched is turning off auto exposure, which is something I changed as I was trying to figure this out.
Thanks for trying to help, hopefully I can figure this out eventually.

1 Like

I don’t see much in google, which usually means, either it’s not happening to anyone else or, I used the wrong search string :wink:

I could be one of these weird level / project dependent things.

If you try a new project and just build light in the default level and package it, does it happen?

So if I create a brand new project, and add a spotlight to the minimal default map that UE4 gives you, I do not have this issue. There is a very brief point right on load where it is barely noticeable, which I would assume is normal loading. If I create a new map however, I have the same issue. :weary:

Meh…

Either it’s just something that always happens, and you have become sensitized to it, how long it the wait?

Or, there’s something up / misconfigured in the engine.

You could try verifying the engine?

image

On the default level, it’s extremely fast and barely noticeable. On other levels, it’s around 5 seconds. I haven’t really worked with lighting all that much until this project, and I have some other levels I had worked on where this doesn’t seem to be an issue, so I’m really confused if I messed something up somewhere.

For anyone else who sees this or ever has a similar issue, I think I found the problem. It’s that I was using BSP brushes. I did a quick test where I converted them to static meshes, and the issue is largely gone. I don’t know if there is another solution to this, but I wanted to replace the BSP brushes with static meshes at some point anyway, so I think this will work for me. Thanks to ClockworkOcean for their patience.

1 Like

Hey, glad you got there.

Yeah, not a big BSP fan myself. I also see a lot of problems stemming from it on here. I think they’re just supposed to be for prototyping.