Download

Lighting seams between static meshes?

When I bake my lighting, the meshes in my scene get baked light in a way that is obvious where the seams are and it’s quite ugly.


This problem is even more noticeable when there are low lighting conditions, and is slightly less noticeable when the area is well lit.
The lighting bake is on production, the lightmap indexes are 128, and they are set to uv channel 1, which has enough space for bleeding.

If you view normals, do the normals match up across the seams?

I think that’s just how it is. You will never get a complete seamless transition between meshes because of lightmaps. You have to hide those seams in a clever way

Hi,

gerbilho is right, you cannot make this completely dissapear. It happens because lighting gets baked into each mesh on a different thread, and it will cause slide shade variations.

Have a look at this thread, maybe you can find some useful tips here to reduce/workaround the issue.

https://forums.unrealengine.com/showthread.php?100221-After-building-lighting-is-all-different-shades

That’s a shame. I suppose a workaround would be to use dynamic cascade shadows, and I’m only guessing that fixes the problem, because I think the baked light could look fine from a distance but I’m not happy how it looks up close. The problem is, it’s an interior so I have no sky or directional lights. With that in mind, how can I use real time lighting/shading without a directional light, and could that even be a fix to this issue?

Your best options are to use larger pieces, or design the scene to not have flat areas meet up like that. If you had a pillar, support beams, intentional seams between the meshes, there wouldn’t be any errors.

Playing with the light mass settings can reduce the errors a bit, but it’s typically not worth the extra bake time.

That’s a shame . I agree… even you hold pixle bitmap… … not effect.