Lighting not smooth

Worked thru some hours of tutorials about lighting, materials and what not… but i can’t get it to the result i want… without even finding the right option to influence the behaviour :frowning:

The lighting seam to be done for every face? Without any interpolation between the vertex which looks quite uggly; as you can see the boxes with hard borders like:

My expectation is smooth lighting from the passiv reflections on floor and white walls, looking on the unlit version down below

The room is made out of boxes, different static mesh actors. The meshes are 8 vertex with 6 faces (windows meshes have more, but similar)


Ok… so…
I think it’s not the best idea to face snap objects: if your lightmap uv is not perfect or you won’t assign a high enough resolution to it, it (shadow parts) will bleed over on the corners/edges… this is for the high variety of shading + "glowing edges…
I would also guess that this is NOT a production build…
Anyway: Unreal does compute light per object so if you don’t go lower with your indirect lighting smoothness you WILL see these shading differences! If you set ILLS to 0.1 - 0.15 and smoothness to 0.6 you will get rid of those!!
…not sure if you’re using portals or Lightmass Importance Volume…

First of all, thanks for the Explanation :slight_smile:

Isnt “face snap objects” not the case for each an everything? I mean, wouldnt that mean that the lighting is always like that, e.g. if i just put book meshes inside of a cupboard or something more detailed for the level? or did i understood you wrong?

The lightmap resolution for each of the 2m x 2m elements is 64 - cant judge if this is high or low for the lightmap on an object of that size.

I tried altought production build, but this makes it just slightly better, the boxes are still fully visible.

I tried “lightmass importance volume”, different kinds of lights/sky/… setups and configurations… but the effect is always there, as soon as i just put a “directional light” as sun inside the scene.

What/Where you mean with “ILLS to 0.1 - 0.15 and smoothness to 0.6” ?

No worries! :slight_smile:

Objects can overlap or snap or float… what I meant was that with baked/built light if your big main walls are face snapped and not corner/edge snapped then the overlapping faces will be in “shades” right? So THAT shadow part (which kind of doesn’t even exist) can “climb” into the visible area (bleed) and will cause problems… I hope I’m not too confusing!! :smiley:

Ok so if you use your own meshes and not the ones that comes in Unreal (bsp) then going higher with your lightmaps you let Unreal to visualize more lighting information! Imagine it as a texture! If you have a low res texture, your result will be low res/blocky!
You can assign a checker material to any of your meshes with the given resolution and then you’ll see how much info you can expect… After like a couple of light build you’ll know exactly what needs what!! /I’d say a 2x2 m wall will need 512/1024<

Those settings I mentioned are under world/lightmass!!

While testing with that settings (and just killing my PC ram with the lightmap resolution…) I can see the kind of “bleeding” effect now, i guess. If i put the “Static lighting level scale” to 0.15 and the light maps to 2048, there are shiny little “spot lights” at the wall edges:

In total, it looks somehow better now at the vertical edges. But from thinking about your explaination, i guess the kind of “work flow” (Blender->fbx->UE) and the geometry as i build it for my prototyping elements will not work for a proper lightbuild. There will be allways this kind of “hidden” faces and from export/importing the vertex seams to have some rounding error, or something like that, to not fit perfectly on each other.

1.the spot lights are lightmap being blurred over. Turn compression off for lightmap.
2. For lightmass some times different objects render just a tad different when they are on separate CPU threads.