Download

LIghting issues-artifacts

HI there,

Dropbox - Error < shows my current WIP, and as you can see, there are these odd looking banks going around mesh, and the artifacting.

There was a UV attached, but it seems on reimport, it didn’t create a channel 1 lightmap which it should given doc page on importing assets. Was no lightmap created because possibly the ‘auto generate LM’ wasn’t selected given I did ‘reimport’ since mesh was already in scene and just being updated ?

Thx
nl

You can generate lightmap UV’s after import as well. Under LOD 0 > Build Settings you’ll see Generate Lightmap UV’s tickbox. Enable it and then hit Apply Changes.

Well dain, that wasn’t it. I found the LOD 0 ( ha, I had accicentally SLID the panel back, thx for reminder, I kept Looking ;)) HA) , but it was already ticked so why wouldn’t there be a UV channel 1 ? I have only channel 0.

On import its supposed to create lightmap which I presume goes onto channel1, as if I had created it myself and it always showed up on 1.

Out of ideas, Hope I’m just missing something obvious.

Cheers
lee

Ok update, I unticked, reticked and applies, and now the artifacting is way worse, I even tried lightmap uv res of 1024, but no diff,so set it back to 64.

I’ll add picture in a moment showing artifacting, and lines are still present in prior url.

EDIT EDIT:I decided to restart, so I did and upon doing so and checking SM editor for mesh, it still shows the tick in box for creating lightmap, yet no such channel exists, and yes I still have the odd artifacting, which I guess makes sense given there is no lightmap info. If I untick, and retick and apply, then the artifacting gets terrible as seen here:

Checked SM editor info again, and after enabling and applying, still no channel 1.

Stumped, any idea ? ;0-0

thx
lee

k I veifed one thing at least, importing into unity 5 and I see no such artifacting, rather disturbing.

I hope somebody has other ideas as if I’ can’t fix this, and on my own I don’t have the tech experience to do so, I may have to switch engines as I won’t be slowed by problems.

Ya its that dire , isn’t it always .

I tried searching for help, best answer was disable CSM, but it was already OFF so that wasn’t it clearly, any other ideas ??

thx
lee