Lighting issue with landscape material

Hi I’m new to Unreal engine and I am following some tutorials in my spare time.
After I’m done with tutorials or on a rainy day when I just want to explore a little of the possibilities of unreal engine I just make a new project… try out some stuff and then see if I run into any issues.

Usually its just moving some sliders and seeing if for example lighting effects change and if I like the result.
So this time I tried to create a landscape and assign a landscape material.
I managed to create the landscape and everything looked fine until I assigned the landscape material!

I get a really bright patch in the middle of the view then an outer ring that’s darker and then it all just turns black!
I tried googling for tutorials and answers but I did not find anything that related to this happening!

Does anyone know how to fix this?
I’m still very new and lack the basics of Unreal Engine and could do with a nudge in the right direction!

Thank you :upside_down_face:

Hi,
For me, it’s look like you’ve not create the layer info for the landscape material as said here. :

Go into you’re landscape window → paint → here you see you’re layer. Click the + button and select Weight-blended Layer (normal). You have to do it for each layer you create !

Hope it help you and Have a nice day !

1 Like

Wow thank you :grin: that fixed it!
Well kind of… I have to take a deeper look at this but for now I’m happy that it at least fixed the visibility issue!
Although now I’m missing some landscape in the top left… no idea what happened there :joy:

By the way I know it all looks a bit rubbish I mean there’s NO quality whatsoever but it is just trying out some stuff… this is NOT a project that leads anywhere but learning by doing!
Thanks for your reply though you made my day! :wink:

1 Like

Hi, Glad it helped ! No problem, i understand :grin:

For some reason, i don’t have a notification for you’re answer, so, sorry for the late response! :sweat_smile: I hope you find a solution for the terrain missing in the corner.

If not.
What i see from what you show, by assuming you’re working with world partition. It’s probably possible that some of you’re landscape tile are unloaded.

If happening in editor :
Go into you’re world partition window. Select region you want and load that region.

If happening in PIE ( Play in editor ) Or standalone game :
Go in you’re editor, open world setting window, find the world partition runtime grid setting and increase the loading range value.

Maybe this can help you find you’re way.

Hope it helps and have a nice day !

1 Like

Hi Steeven…
Yes it was the world partition… I found out how to fix that too kind of… there’s so much to learn :sweat_smile: phewwww and so little time to do it…
I’m currently doing a youtube tutorial and its making a game from beginning to end!
I’m just going to follow along and pick up as much as I can!
Its quite fun to see how things work and its also very rewarding to see results!
Hope you have a nice day too :wink: