Lighting freezes during build at 0% on Mac OS X


This is a common problem it seems, a quick research returns dozens of similar cases. I just wanted to share another experience

I use UE4 under Mac OS X (MBP retina 2012). I use an extremely simple model, with only 3 light sources, so nothing our of ordinary.

Here is a pic :

I have tried various lighting parameters (preview, and others) and tried to cancel build and rebuild lighting only. It always stops at 0%

Same here, on a mid 2012 iMac. Builds everything else fine then stops on lighting build and never gets past 0%.

I have same problem.

same problem here

I’m experiencing same issue as well using Unreal Engine 4.2 on OSX 10.9.3.

I’ve seen one solution to this being disabling (or adding specific allow rules for UnrealLightmass to) OSX firewall however that hasn’t solved issue for me.

Hey yazybones (and anyone else still experiencing this problem),

Can you tell us your system specs? You can find this here: About This Mac > More Info.

Does this happen in every project? If you start a new project does same issue occur? Did this occur in 4.1 or did it only appear in 4.2?


I have it in every project that I create.

Processor: 3.4 GHz Intel Core i7
Memory: 16GB 1333 MHz DDR3
Graphics: AMD Radeon HD 6970M 2048 MB
OS X 10.9.3

It’s always happened in all ue4 versions.

Are you using binary build installed via Launcher, or you built editor yourself using code from GitHub?

Hi ,

System specs are: 3.2GHz Intel Core i5, 16GB 1600 MHz DDR3, NVIDIA GeForce GTX 680MX 2048MB.

This happens in every project (even a new blank one) and has happened in all versions of UE4. I’m using binary build installed via Launcher.

Thanks guys,

We’re looking into this now and will let you know if we’re able to see what’s causing issue. If you are able to narrow down cause at all, please let us know here. Thanks!

I’m using a binary build from launcher. Currently 4.4.3 and I still have same issue.

Could it be related to this issue (Lightmass blocked by firewall)?

It’s very likely, yes. Thanks for linking this post!

Thanks - had same issue and tried to allow incoming connections for the - Lightmass which was blocked by firewall.

Folks, I had this issue and unblocking lightmass in firewall worked for UNREAL EDITOR but I still CANNOT get lights to build in UNREAL TOURNAMENT MAP EDITOR.
Someone mentioned “building lightmass with xcode” but I have no idea what that means or how to go about it. Anyone?

Hi sincitycyclops,

You’re probably facing a different issue than this. Please open a new post with as many details about issue you’re running into now so we can look at it. Thanks!

There are a ton of posts about this already. Seems either people are not getting answers or getting answers that don’t work for them. I am happy to open yet another post about it but then I just end up spending tons of time searching other posts for someone who finally gives an answer to this problem.

This post is originally from April of 2014, very shortly after UE4 was released, so we’d like to take a fresh stab at it. Link your new post here or post it in Bug Reports and I’ll see it and assign it to our staff to look into.