Lighting error: hard border where light stops


I am setting up the lighting for my scene in a large warehouse. The directional light from the sun shines through the windows and appears to work correctly. Now I also want to add light sources inside, but when I build the lighting (at any quality setting) there will be a hard border across the scene, where the effect of the light source stops.

as you can see, the cone of this spotlight is fairly big, but more than half of it is not affected by it. Note that the directional light still hits the dark area.

I tested this with multiple lights, point lights and how the position influences this border. But I couldn’t find any pattern why or where this border appears, only that it is not directly dependant on the lights position.

Does anyone know what might be causing this issue, or how to troubleshoot it?

If it helps, both lights are set to stationary and the floor is static (default).

Here is another screen-shot without the cone of the spotlight:

Hi ck20ab,

Do you happen to have “Area Shadows” enabled on your spot light and is it set to Stationary? If so, you can either disable Area Shadows and rebuild to see if that solves it. If that ends up being the issue this is fixed in 4.14 and you can test this in the 4.14 Preview release that is currently available in the launcher.

If you don’t suspect this to be your issue, please post more detailed information about any and all light settings that have been adjusted, along with more details about the meshes and setups for your scene. A sample project is helpful if you need feedback more quickly with the issue, but not necessarily required.

Let me know.


Thanks for the reply.

Area Shadows was disabled, so that was not my problem, but for some reason the Static mesh of the warehouse was set to stationary. I set it to static and now this problem is gone. I still don’t quite understand why this would cause an issue, but at least it’s fixed for now. Unfortunately the shadows on and by the warehouse are much worse now, so I’ll have to do something about my Light map.