Lighting Builder Doesn't Merge Spline Meshes

Lighting builder doesn’t merge spline meshes. So that, transitions are getting sharp. I found a workaround for this issue.

1.Create a blueprint actor

2.Program a road creator that uses spline meshes

Then workaround starts here:

3.Create a cube as a child of Spline

4.Under details tab of the cube; set mobility to Static, then check Light Attachments as Group

5.After creating each spline mesh, attach them to the cube using AttachTo function.

6.Build lighting.

These steps solve the problem and I was able to reproduce again and again. Considering spline meshes are mostly used for constructing continous roads in the blueprint actors, sharp edges are unexpected results for the developers. I think this should be a default specification of the engine.

Hello SalihBalkan,

Your first couple of steps are very broad reaching, and it would be easier to test this issue on my end, if you supplied us with a test project. You mention it is easy to reproduce it consistently on your end, so if you could provide me with a project that would be helpful.

Simply zip your Config, Content, and .Uproject folders/files into a compressed zip folder. Then upload it to an external share drive like Google Drive and provide me with a link via a private message on the forums.

If this is not a viable solution, I am going to need some simplified beginning steps to reproduce the issue on my end. One guess is that this could be a bounds scale issue, but it is hard to determine as I would need some visual context.

Let me know if you have further comments or questions.


Hi , since I changed my level a lot, I wasn’t able to reproduce those very sharp edges. Lightmap resolution of the road plane and side blocks are 64. There is no overlapping on the lightmaps. However, I can still see differences like this:

When attachment node is disabled:

When attachment node is enabled:
Red circle is okay but transition between road planes are a little bit sharp as you can see near the spline point. Also right hand side blocks are still shining like orange.

I think I am on the wrong way to solve this problem. Do you know a proper way to fix this? I still couldn’t sent assets that you need because I am very
busy nowadays, do you still need them or are these images are enough?

edit: Oh, I just remember that I multiplied the size of the right hand side blocks by -1, I think that’s why it rendered incorrect.