Download

Lighting Build Confusion

Hi All,

Total noob here so sorry that it is a dumb question. Can anyone give me a ballpark time on building the lighting for a very simple level. I’ve just got a single corridor, with one light in it, windows, and the light source outside, and when I attempt to rebuild lighting it just seems to sit there saying that it’s building lighting and stays at 0%. The output log says this initially:

LightingResults: New page: Lighting Build - 23/03/2014 3:40:45 am
LogStaticLightingSystem:Warning: No importance volume found, so the scene bounding box was used. You can optimize your scene’s quality and lighting build times by adding importance volumes.
LogStaticLightingSystem: Running Lightmass w/ ImmediateImport mode ENABLED
LogStaticLightingSystem: Running Lightmass w/ ImmediateProcess mode ENABLED
LogStaticLightingSystem: Running Lightmass w/ Sorting mode ENABLED
LogStaticLightingSystem: Running Lightmass w/ Mapping paddings ENABLED
LogStaticLightingSystem: Running Lightmass w/ Mapping debug paddings DISABLED
LogEditorBuildUtils: Build time 0:00:00
LogMaterial: Missing cached shader map for material FLightmassMaterialRenderer M_Glass, compiling.
LogMaterial: Missing cached shader map for material FLightmassMaterialRenderer M_Glass, compiling.
LogMaterial: Missing cached shader map for material FLightmassMaterialRenderer M_VerticalLights, compiling.
LogMaterial: Missing cached shader map for material FLightmassMaterialRenderer M_VerticalLights, compiling.
LogMaterial: Missing cached shader map for material FLightmassMaterialRenderer M_VerticalLights, compiling.
LogMaterial: Missing cached shader map for material FLightmassMaterialRenderer M_Dark_Wall, compiling.
LogMaterial: Missing cached shader map for material FLightmassMaterialRenderer M_Dark_Wall, compiling.
LogMaterial: Missing cached shader map for material FLightmassMaterialRenderer M_Dark_Wall, compiling.
LogMaterial: Missing cached shader map for material FLightmassMaterialRenderer M_Metal_Steel, compiling.
LogMaterial: Missing cached shader map for material FLightmassMaterialRenderer M_Metal_Steel, compiling.
LogMaterial: Missing cached shader map for material FLightmassMaterialRenderer M_Metal_Steel, compiling.
LogMaterial: Missing cached shader map for material FLightmassMaterialRenderer M_Metal_Chrome, compiling.
LogMaterial: Missing cached shader map for material FLightmassMaterialRenderer M_Metal_Chrome, compiling.
LogMaterial: Missing cached shader map for material FLightmassMaterialRenderer M_Metal_Chrome, compiling.

But it doesn’t say anything else after the first few seconds, and I’ve been waiting for 15 minutes now. Just wondering if I have to be patient, or if there is something wrong. Appreciate any info you guys could provide.

Cheers,
Aaron

A hint in the log. LogStaticLightingSystem:Warning: No importance volume found, so the scene bounding box was used. You can optimize your scene’s quality and lighting build times by adding importance volumes.
Add a Lightmass Importance Volume around your play area and try that.

As pootsz says, add an Importance Volume, it will speed up small scenes a lot.

However, I’ve seen the build get stuck on Building Lighting 0% a few times - it should progress quickly (the last phase seems to be the longest, in my tests anyway), so if it doesn’t try cancelling and building again.

Could be that this is the main offender: LogMaterial: Missing cached shader map for material FLightmassMaterialRenderer M_Metal_Chrome, compiling.

You could try to add the following console command: “recompileshaders all” or “recompileshaders changed” which will then take a while depending on how much it needs to recompile, but it could be the case that this actually fixes it :wink:

If not, I am sorry and dont know how to fix it :smiley:

How fast is your CPU? Do you see your CPU spikeing when you do a build? Can you post a picture of what your swarm build app is doing? All this and more can help us help you out:).

Hi again all,

Thanks for your replies! I have tried the following:

  • Added an importance volume, didn’t seem to fix it.
  • Tried on a different, even simpler map, still seems to get stuck, and the log shows none of the warnings listed in my initial post.
  • Have tried on two different machines also.

Things to note:

  • I’m developing in Mac OSX… so it could be related to this.
  • One of my machines is a 2.6Ghz i7 MacBook Pro, the other is my iMac which is also an i7 (can’t remember the Ghz and am at work at the moment).
  • I have built the engine from the full source, and then created a FPS Template (C++) project, so the editor for this project is being built through Xcode also.
  • I do notice the CPU being utilised and also a framerate drop in the editor when it begins building the lighting, however I have left it there for hours and it never gets past zero percent.

Samsterdam, I’m a little confused about what you mean by this:
“Can you post a picture of what your swarm build app is doing?”
Can you elaborate on what you’re after here?

At this point I’m running out of things to try so any more suggestions would be great. If I can’t resolve it, my next step will be to boot in to Windows, set everything up in there, and see if things work a little smoother. I understand the Mac OSX support is not fully tested at this point, but everything else seems to be working quite well, and if possible, I’d like to continue working in the Mac environment as I think building the mac community for the engine is a good thing.

Again, I appreciate everyone’s help!

I’m having the same problem and I’m using an overclocked i7-4770K and 2x R9 290X’s in Crossfire (a powerful windows PC)

By the looks of it, it’s a cross platform error, not just OS X, I’m sure that it will be updated soon.

Any news on this?
I’m on OS X and my building lighting is stuck at 0% too. If I use the editor downloaded from the launcher everything works. Using my own compiled binary even after hours it’s not going any further than 0%. I’m using development scheme for compilation.

I got a question. What is an “Importance Volume” I have seen this posted in other places and I cant figure out what it is. I have look at the light mass settings for something about this and I am drawing a blank.

It’s an important volume, meaning, it give a specified bounding box importance in terms of baking lights. From hourences: "A LM importance volume is a special volume that determines how high the quality should be in a specific area. So everything inside one of those volumes will receive full quality lighting, the parts outside these volumes however will be lower in quality. "

Ok. So where do I find the means to change our add this value. I ask because I am having a lightmass warning problem. Pretty much it says my map is so large I need an importance volume to bound the light mass or something. I cant look for the exact warning because unreal is updating.

It’s under volumes or all under your placement options on the top left hand side of the screen, where you’d also find sphere