Lighting bug on movable objects when baking static lighting.

Hi,

While investigating how to improve lighting in one of our scenes we noticed that the static directional lighting is behaving in a way we didn’t expect.

There is a little hot spot on movable objects which appears opposite to the directional light forward vector.

In this screenshot, the large spheres are meshes and the small spheres are the volumetric lightmap visualization.
The mesh on the left is Static. The mesh on the right is Moveable.

The directional light is Static, and the lighting has been baked

The hotspot appears to be baked into the Volumetric Lightmap as you can see it on the small debug spheres.

I have attached the sample project I took this screenshot from [here][1]

Changing the Directional Light to ‘Stationary’ removes this little hotspot. But we would prefer to use Static lights for everything.

My question is - is this behavior normal? Is it something which can be fixed?

Thanks,

Tom

Haven’t had a chance to go through your project, but it looks like bounce light from the surface? Perhaps reduce the indirect light bounce of the direction light or use a gi replace node in the surface material and put it black.
You could also try lower volumetric light map details to get more fidelity on your movable object

Disable the sphere reflection capture, seems like an indirectlight coming from the bottom.

Just giving an update to say I found a way to suppress the issue by increasing the ‘Volumetric Lightmap Spherical Harmonic Smoothing’ from the default of 0.02 to 0.04

Hovering over the parameter in the editor kind of helps explain why this is. Or at least pointed me in the right direction.

The result is that it the hotspot is removed, but the volumetric lighting is slightly spread further across the surface.