Lighting and Bloom effects appear in editor, not in viewport/simulation.

So I have a blueprint that consists of a room with many neon lights(emmisive materials), as well as a point light in it. If I look in the blueprint editor, it is beautifully lit, nice bloom on the lights and everything. When I place it in the world, it is dark and there is zero bloom.

I never consciously turned off any kind of rendering effects, but it appears I have. If I look at the Global PostProcess object in the world (the one that came with the template), bloom intensity is turned on, value .5 (cranking it up had no effect).

Doing build > build lighting only , also has no effect.

Any ideas where I went wrong?

Hey hypersapien -

Can you check you Engine Scalability settings and make sure that they are set for Epic?

Thank You

Eric Ketchum

Hey hypersapien,

Check to see if your ‘Post Process’ settings in your level are causing this to happen. Go into your ‘World Outliner’ and find your ‘Post Process Volume’. Click the little eyeball to turn off the volume temporarily and take a look at your Blueprint while in the world.

If you see it change then you can assume this is affecting your Blueprint. One of the settings I would inspect within the volume is ‘Auto Exposure.’

Let me know if these suggestions resolved your issue or if you need further assistance.

Regards,

Andrew Hurley

Thanks for the suggestions, but I haven’t yet solved the problem. Here are the things I’ve tried, none have fixed the issue.

  • Checked the Engine Scalability settings (They are and have always been set to ‘Epic’)
  • Deleted my 'Intermediate" and ‘Saved’ folders within my main project folder
  • Turned off Global PostProcess as AndrewHurley sugested (No change)
  • Copied over the Global PostProcess from the FPS template (no change)
  • Copied over the Lightmassimportancevolume from the FPS template (no change *INITIALLY)

I am still a novice to this, so I don’t know the ins and outs of how to use the light mass importance volume, but I started with making the volume fully contain my scene- no change here. However, on a lark I just decided to scale the volume up vastly bigger than my scene (maybe 3 to 4 times as large). Once I did this, and rebuilt the lighting, my scene brightened up similar to what you see on the left side of my screenshot. It did NOT however, fix the missing bloom issue.

I also tried toggling switches in the Post Processing > auto exposure area. I may have seen the smallest shift in brightness when i turned off the bias, but otherwise it didn’t seem related to my problem.

Hey again hypersapien,

I know you mentioned you toggled some switched in the Post Process Volume, but try entering the values you see in the images.

Be sure your Post Process Volume is set to Unbound

This setting can be toggled within the ‘Post Process Volume’ section of the actor.

Default Exposure

Here is what the default values of the Post Process Volume look like.

Desired Exposure

If after double checking this and you still see no change, please let me know and we can continue to troubleshoot.

Cheers,

Andrew Hurley

Thank you. I may be too busy to work on this tonight, but certainly by tomorrow I will try that.

Note: I am currently working in 4.7.2.

I once constructed this scene in a different version, either 4.5 or 4.6, and the lighting and effects worked wonderfully right out-of-the-box. I literally set no quality values or special effects up, as I was brand new to UE4.

For unrelated reasons, I had to completely start over on this project and build it from scratch once I was using 4.7. To the best of my knowledge, I constructed it in the same manner I had used previously, but those nice lighting effects are absent now. Is there anything different about v4.7 regarding the use of these lighting effects?

I will report back tomorrow-ish.

You are welcome.

Whenever we release a new version of the Engine, a thread is created on the release notes for the version or hotfix. This can be found within the Announcements and Releases section.

For the full release notes, have a look at the Documentation page as well as the Forum thread.

Full Release Notes

https://docs.unrealengine.com/latest/INT/Support/Builds/ReleaseNotes/2015/4_7/index.html

Release Highlights Thread

Unreal Engine 4.7 Released! - Announcements - Unreal Engine Forums!

There we a lot of really great changes integrated into 4.7 so have a read and see if you can find anything worth noting.

Cheers,

Andrew Hurley

Sorry for the late reply. Had a family illness keeping me from this project.

I tried those settings, with the Unbound box ticked, I see a minor shift in brightness. To quantify the difference I’m seeing, if I estimate your screenshots as being a brightness increase of 100%, mine has a brightness increase of maybe 5% (barely noticeable).

Hey hypersapien,

Just to mention, there were some config settings within your ‘Project Settings’ options under the ‘Rendering’ section that deal directly with some of these lighting effects.

Default Post Processing

34544-defaultpostprocess.png

These options are usually all checked on by default. If they are all checked, you might then want to have a look at your ‘Engine Scalability Settings’.

Engine Scalability Settings

Hopefully one of these suggestions work, but if you still need help let me know and we can try something different.

Cheers,

Andrew Hurley

My settings match those exactly.

I come bearing new clues. I cranked my emissive value way up to 20 (initial value in the first screenshots I posted was at 5). My viewport/play test now is showing bloom, so I now know it is not outright disabled.

However, it still seems buggy. In the blueprint editor I was getting nice, clean bloom at a value of 5, in my main viewport I only begin to see bloom at a value of 19, and then at 20 its extremely bright. Furthermore it doesn’t seem as clean, meaning not all surfaces displaying this material seem to have the same brightness (in the blueprint editor, they do).

Made some screenshots to better demonstrate what I’m talking about.

(Main viewport appears the same as play testing)

Top Left Image: Blooming evenly, but too bright. (See original post for an example of of how I would like it to look)

Top Right Image: Some surfaces don’t display bloom at all, and the ones that do don’t seem to be blooming evenly around the edges like I might expect.

Lower Left Image: Not a noticable difference from the top left image.

Lower Right Image: Suddenly, bloom is too intense, and lens flares have gone crazy (particularly noticeable when in motion). I tried choosing values between 19 and 20, but struggled with the inconsistent bloom seen in the upper right image. As soon as I get all surfaces blooming equally, brightness is too intense.

Hey hypersapien,

So the reason you are probably seeing the large differences between the values of 19 and 20 are due to the ‘Auto-Exposure’ and lights within your scene. The lens flares can be disabled completely or reduced to an extent in which you can barely see them.

Another setting that might be greatly affecting these radical differences is the ‘Bloom’ and the ‘Bloom Threshold’. If you are thinking the settings of your post process are not functioning correctly you can go into your Unreal Projects folder and delete the config file associated with this project. Make a copy first!

This way you are able to fully revert the Post Process settings to their default state. Keep in mind, you will always have some differences between the way your mesh looks in the Blueprint editor versus in the Scene itself, due to the lighting differences.

If you come to a point where you have exhausted all of your options and still are not getting the results you would like, let me know and we can try getting your asset to me for testing.

Cheers,

Andrew Hurley

Thanks. I’ll consider this solved then. I’ll still need to tinker with things on my own, but it seems too nuanced to carry on here.

I accept the fact that the editor window and the main view port may handle graphics differently, I just find it unsettling that that I seem to have a lot more control and predictable finesse in the editor window compared to the main viewport.

The lighting should be identical in my screenshots. There is only 1 light source (a point light) which is contained in the blueprint. The only things in my world that is not in the blueprint are a light importance volume and the global post process volume.

I know it may be late, but you can turn off your SphereReflectionCapture. It seemed to work for me.

I have same problem in 4.12 - standalone mode is Darker and work properlly. Editor viewport increase the value in AutoExposure postprocess.

Would it not be possibly due to the default light that is lighting the Blueprint Editor Viewport? I have been trying to find a way to disable the default light in the Blueprint Editor as I am adding custom lights to lght my static mesh in my blueprint on a seperate channel fromt he rest of the world for creating render targets for icons in widgets. I hve found it annoying to get the lighting correct as I have to render to target to see the actual lighting as the blueprint viewport is over-lit because of the default light…I realize I am years behind on this post but did not really see a solution or reason in this thread and it may be relating to my situation.