Light turns darker and brighter randomly on editor and game mode

I’ve turned auto exposure off on post process volume, project settings and on my character as well. Other than that I couldn’t find anything else that was actually causing exposure to come out in my scene (at least not that I know of). At this point I’m not really sure what to do. Some help would be extremely appreciated. I also checked out most of the posts that had something to do with this and tried what was suggested. Still no luck. The first image is what the lighting should look like. The second image is what comes out randomly even without auto exposure and it just flickers like that every time I turn the camera in the viewport


I don’t fully understand your problem…
When you turn around the walls flickering between dark and bright?
…or you would like to have a darker scene and your lighting turns out too bright?

So the first screenshot is what the lighting should be. However, the second screen shot is what the lighting turns out to be instead. Except this isn’t about whether the scene is too dark or bright but rather the lights are just flickering between those two images. The light is just constantly changing when I turn the camera or move it which isn’t natural. I have a spotlight on top of a particle effect if that helps in anyway.

I’ve seen posts about this kind of errors with scenes downloaded from the marketplace… I don’t remember what was the solution! :S
…when this happened to me it was always because of overlapping faces… but I guess in your case it will be something else…

most of the posts I saw were about auto exposure being turned on which I turned off so it doesn’t seem like my solution is in that department. The only thing I can think of that might be the solution is something with the particles interacting with the spotlight in the scene. But then again… I’m not sure.