Light settings Issue

The images I have attached on this post belong to the same project and the same maps. The first one (Img_01) is what I see using my computer desktop and the second one is what I see using my laptop. I do not know if it is a light preset settings from unreal engine or it is due to the computers features.

*Img_01 - iMac 21.5" / Win10 Bootcamp / 2015
**Img_02 - MacBook Pro 15" / Win10 Bootcamp / 2012

To me this looks like your laptop graphics card is not able to handle HDR lighting. To test this theory, you could try changing the post processing setting for “Auto Exposure” so that the Min and Max are both set to 1. Then adjust the Bias value until it looks decent. Then check it on both machines again.

Thanks for the answer . I think my iMac graphics card doesn´t run properly because, as you can see on the image attached, the HDR lighting reflect through the column and reflect on the floor in front of that column.

I have searched my lastest drivers installed and there are no newer. I don´t know how to fix it…

To me, the iMac image looks correct and the laptop image looks incorrect, so I’m a bit confused by your comment. When you face the camera at very bright areas and then very dark areas do you see the exposure (overall brightness) adjust? Or does the brightness always stay locked at one level? If HDR lighting is working then you should see it adjust based on the brightness of the area your camera is pointing at.

The images didn´t upload before. Sorry about that. I attach a new one where you can see the difference between the scene running on both computers. HDR lights are not being building correctly on the iMac, however, when the scene runs on the laptop HDR lights are ok. Could be a light preset setting by default when I installed UE4 on each computer?


*iMac 21.5’’ - NVIDIA GFORCE 750M
*Macbook Pro - NVIDIA GFORCE 600

**Both of them are updated.

It’s not the lighting that looks at fault to me in those images. It looks like the reflections that are different. The laptop appears to be using Screen Space Reflections (accurate reflections) but the iMac is not. What are your editor quality settings set to on both machines? (under “Settings > Engine Scalability Settings”) If you set everything to “Epic” quality do you see a change?

Awesome man! you were completly right!! Not only HDR shadows are working properly but, all shaders have increased pretty much theirs quality.

Thank you very much!!

miguel, glad I could help. Looks great, BTW! Would you be willing to share whatever image you’re using outside the window? I’m always looking for good environment images for archvis-like stuff. If you can’t share I totally understand.

What´s your e-mail?

I just sent you a PM on the forums with my email address. Thanks!