Light question 4.10.2

Hey Epic people.
I have a question related to the recently 4.10.2 update.
I’ve just updated my unreal engine, but the planes I used as reflectors for my windows, don’t reflect anymore. I was reading about the update on lighmass portals on the 4.11 update, and I’ve become a bit confused if there’s actually a new way to deal with light through windows.
Here’s a printscreen of my problem.
Thank’s in advance.

Hello Okdraw,

Would you mind providing a screenshot of the material you are using on your planes. I will take a closer look into whether or not any functionality has been changed.

Hey .
Sure, here’s the material I had at the time of that printscreen:

I’ve also tried to increase the specular and reduce the roughness, but the result was the same. Here’s a printscreen of the material with more reflection:


I set up a small test with the same material as you have linked in your second screenshot.

In order to see reflections you will need to add a slight metal value. 0 for the metallic value disables metal. Even though you have a value for the metal channel you are giving it an input of 0.

Here is a few screenshots of a BSP made room with a thin cube for the window to illustrate this. The first screenshot is of your material as you have it set up in your second screenshot.

As you can see there is light picking up value due to the input for your specularity. Note the lack of materials reflected and at this angle this is where I see the light bounce.

This next screenshot is a little closer and with a metallic value of .2

Notice the increased amount of reflected information of both lights and even textures.

This last screenshot is with a metallic value of .8.

Now I have a much clearer reflection of the interior of this scene. This is due to how metallic feature react with lights and the amount of light that is reflected back off the surface.

It could be due to the update itself. Make a copy of your project before testing this. Deleting the Saved, Intermediate, and Derived Data cache from your projects directories will force your project to rebuild when you open it next. This should clear up any unwanted information that has been transferred from an older version of UE4.

It doesn’t seem to work. It just turns the planes like mirrors.
Here’s an image of the result:

And here’s an image of how it was before the update:

It’s weird how an update changed this.

To clarify you have updated from 4.10.1 to 4.10.2? I am currently investigating any changes that have been made in 4.10.2. that could be causing this.

Yes, from 4.10.1 to 4.10.2. Thanks

I ran a test and created a scene in 4.10.1. Then I updated it to 4.10.2. Again, I did not see the change like you are experiencing. I do see a slight increase in the intensity of the reflection. Do you have Eye adaptation enabled in both projects?

These are my results.

The above image is from 4.10.1.

The second image is the update to 4.10.2.

I don’t have eye adaptation enable in either projects. I can’t really understand what’s happenning, but I might try some emisse material instead, or just forget about the reflector panels. I don’t know.
Thanks anyway.

I’ve just used some emissive material and it did the trick. Problem solved. Thanks