Download

Light Propagation Volume doesn't work in 4.22

Hi,
I started my project in 4.20 and was using LPV. Everything was fine and I was very happy with it.
Now in 4.22 the LPV shows no effect anymore.

So I am wondering, if something like raytracing or so (which my hardware - GeForce1050 doesn’t support) is disabling the LPV.

Attached you find the settings for the parallel light, the Post Process Volume and a shot, how it looks.
I even made a new file [projekt]/Config/ConsoleVariables.ini with the settings



[Startup]
; ...
net.UseAdaptiveNetUpdateFrequency=0
r.LightPropagationVolume = 1


LPV simply doesnt work.
You have to revert to a version where it still worked if you want to use it.

:frowning:
Thank you, but why are there still the settings?

Is there an official pronouncement on this?

It’s an experimental feature. You cannot expect stable version or a specific focus from Epic team on it. Basically, you can play with it, but you shouldn’t develop with it. It hasn’t been debug since long time. It was a early implementation years ago. With the new render pipeline, there are possibilities that it will be not supported at all without debugging from the team, and it’s probably not a priority for Epic (Raytrace / Render pipeline / current lightmass).

https://docs.unrealengine.com/en-us/…agationVolumes
“Light Propagation Volumes are a feature in development and not ready for production.”

It works for me in 4.22. make sure youve enabled the plugin as well.

The solution is here:

https://answers.unrealengine.com/sto…79-capture.png

Adding a Consoelvaribles.ini to the project directory does not work. You need to add the line to the DefaultEngine.ini in RederSettings in order for it to build with your project.

That still doesn’t appear to work in 22.3. I can see the effect of LPV’s in the editor but not in PIE or in Standalone Game…

Hmmm actually that’s not true. I started a new, blank project and enabled LPV before I started working and they worked fin both in-editor and PIE/Stand Alone. I simply added the require command to the ConsolveVariables.ini and it worked.

There must have been a setting activated during my development that has prevented LPV’s from working. I’m rebuilding my project any and will test what, if anything, I do that disables LPV’s in my 4,22 project.

I too have been tring in UE4.21 and cannot get it to work, plug in is also installed, did all of the above and followed a few videos too.

I just got my rtx2070 and tried out Ray Tracing GI.
Unfortunately I have to tell you, that it kinda works, but it’s way to expensive to be a good solution.
Especialy when you want to use more then one bounce.

thanks TheArtGuy it works for me

Ahm, I"ve read many times, that epic has abandoned LPV,and while its there, its not being worked on curently so no updates coming( given url statements ):

https://forums.unrealengine.com/unre…consoles/page2

As seen above,Epic never commented on thread, nuff said, its not their choice of lighting system, so I’'m not going anywhere near it.
Future is prob.in RTX based ray tracing,and for all others whose projects are OK with it, FAR superior static/stationary lighting bc well, you take no huge perf.hit other than hdd/ssd space , or so I’m told.