Light flickering on meshes - using nothing but emissive textures

Here’s what it looks like: UE5 - Light flickering? - YouTube

There’s no overlapping meshes in here, and all the meshes were cleaned up in Blender using merge vertices. Everything is set to static mobility (whenever applicable).

There’ no other light sources in this scene besides emissive textures. I disabled the post-process volume, atmospheric fog, etc., there’s nothing but meshes in the level. The materials have base color + normal at least, maybe roughness and/or specular, nothing too complicated.

I tried baking lighting, didn’t help, tried baking using GPU Lightmass, still the same.

Setting the view mode to lighting only produced the same results.

However, setting the view mode to path tracing looks amazing (does not have the flicker effect, for one), but it takes a while to fully render (about 5 seconds), so making sure that everything is configured correctly is a bit of a hassle. I’m not developing a game, all the output will be pre-rendered, so should I even care that it’s flickering?

ps: My PC is a 6600k and a 3090Ti with 32GB RAM. Running UE 5.1

Hey @vardonir!

The issue here may be more to do with the shadows rater than the light themselves. Here are a few possible solutions to the issue, the first from another forum post, the second from a Non-Epic affiliated video on Lumen:

I would also look into virtual shadow maps as they may also be playing a hand.

I hope the above leads you to the solution you need!

Thanks for the links!

Unfortunately, setting those values (StochasticInterpolation, and the ones in the video) didn’t help. I think those were intended for grainy/noisy shadows - mine weren’t.

I did notice that I didn’t get the flickering effect unless my emissive mesh was practically on the surface of another non-emissive mesh (see here: UE5 - Flickering from emissive mesh under another mesh - YouTube I tried a point light first and it looked fine, then I tried an emissive cube, which also looked fine. Then it started going bad when I lowered the cube down the mesh of the road). Is this expected?