Light Bleeding Archviz

Hi everyone! I’m owrking on a Archviz project for quite a while and I’m completely stucked with one static mesh that keeps bleeding light from the directional light. I tried absolutely everything before posting it here, these is what I’ve done:

  • Created a lightmap manually on my 3D package, same result as the automatic ones created by the engine.
  • Increased lightmap resolution to 1024 (as you can see in the image is red)
  • Surrounded the bleeding area with unreal cubes to stop the light going in, same result.
  • Tried around 25 different world settings options, same result (or worse sometimes)
  • Directional Light / Skylight / World Settings are on default values for the screenshots

All other objects in the scene are exactly modelled the same way and no other wall is causing me any bleeding issues, I’m starting to think this is a bug but I tried 3 different engines (4.21,4.22,4.23) and the result is always the same, I’m starting to get crazy regarding this. Does anyone know what I’m doing wrong or what else I could try to fix this? Thank you!

To darthviper107, yes it does. The wall you see with light bleeding actually extends outside as behind of it there’s the bathroom that is slightly larger than the room you see, see attached picture. Thanks for getting back.

To **Bathil,**thanks for sharing that information. I started modelling like that back then but the problem I encountered later on during my training was that contiguous walls like the ones you showed were impossible to bake properly as you had to crank the lightmaps settings so high the engine tend to crash, not to mention the ammount of UV tiles you will need if you want to texture them. In my expereience that way is great if you’re planning to use those assets just for rendering purposes within the 3D application of your choice as you don’t depend on lightmaps, but if you were planing to bring that into Unreal it wouldn’t work from an optimisation perspective. Also, are your walls hollow? Why is that? I might be wrong but I tried modelling it the same way you showing me and the results were far worse than what I’ve got right now, let me know.

After posting this I decided to remodel both walls (left and the bleeding one), I merged them creating kind of T shape, created custom lightmaps and reimported into Unreal, built light and the result was exactly the same, how is that even possible?

Thank you very much for the information darthviper107, I really apprecciate it. I followed your advice and didn’t see any improvement whatsoever so I came across the distance field mesh documentation which was completely new for me. I turn the opotion on, change the resolution scale on that particular mesh, built the light in production settings and seemed to have fixed it but not entirely, but nothing compared to before so I will leave it like this as is not noticeable as it was before. Thanks again!