"Light as if Static" unexpected behavor

I would like some of these moving objects to just use lightmaps so using the “light as if static” toggle seemed perfect… except when the object is then moved it seems to blend away from using the lightmap for some reason, resulting in the door becoming black as it rotates open. This seems like a bug to me, or perhaps I’m doing something wrong? Please help. Thank you!

Why not just keep the object dynamically lit? Baking lighting on a movable object and then moving it isn’t always a good idea.

If you are worried about the difference in lighting for dynamic objects in a statically lit environment you can increase the volume light sample placement (set it to a lower value than 1.0) to increase the number of samples placed. This will work to light movable objects in a statically lit area more accurately. No shadow casting ofcourse, unless there is some type of dynamic light near by, but it can help.

Good question, there are a few reasons - as you say the lighting sometimes won’t match as well, for instance it’s impossible to get soft shadows etc. Also the performance is better with static lighting which is important for VR. I’m porting my game over from UE3 and there was an option there that worked to keep moving objects static lit using the lightmaps, it ended up working well for 95% of the objects. I assume that’s what this option is supposed to do but it doesn’t seem to work quite right.

Hi there,

I’m having the same problem on a project I\m working on - did you ever find a resolution to this?


Nope, I’m surprised more people don’t find it an issue, maybe not many people use it. I might have to keep a lot of that stuff dynamically lit if there isn’t a solution which sucks because it will look a bit worse and lower performance especially on mobile etc.