Leaves on tree are completely black after building lighting

Despite looking as expected before I built the lighting, the leaves now look as if they are totally black after building the lighting. This can be fixed by making the leaves slightly emissive, but obviously this is not an idea solution, because it messes up shadows on the floor. I’ve uploaded the tree and the material settings. If it’s related, the bark and leaves are seperate meshes.

It appears that there was no light map on the mesh. I will work on solving this problem next!

Not having a lightmap could be the only problem it was. If not, there’s a setting that has to be enabled in the Show flags (by clicking the Show button in upper left of viewport) which is for lighting. Lighting components is one list (enable all of those to assure it’s one of those), and a few others concerning lighting in there could do it too.