Launching a session I get failed to initialize dependency module is there a fix for this?

Video of issue - set to private so only those with the link / url can view

I have been building a map maybe 6-8 weeks it is close to completion now, yesterday everything was working fine I could launch session but now I get the message instantly on trying to test the map in a session - failed to initialize dependency module

I did download from the Epic Store a Niagra pack called “Niagara Effect Mix 5 and 1 more” which I purchased, migrated it to my UEFN projects and I did drag one of the materials onto some objects which looked super cool but the map then stopped launching.

I did the CTRL+Z to undo everything but having no joy, really gutted as the map has so much work in it, would love to get this finished and published.

I read an older post where it said that this is an older problem more with bringing over Creative 1.0 maps and also using Dropbox to store maps. I do get a dropbox message but had no issues before and have approx 5 other maps in the works, the map is new with UEFN I never played Fortnite before and had previously not used Creative 1.0 so am fresh / new with UEFN.

LogOnline: Error: EOS: UEOSSettings::GetSelectedArtifactSettings() ArtifactName=[Fortnite] no settings found.

LogOnline: Error: EOS: FOnlineSubsystemEOS::PlatformCreate() GetSelectedArtifactSettings failed

LogHotfixManager: Error: Only 156 of 158 assets were successfully patched from ‘AssetHotfix’ section in the Game .ini file. The patched assets will be forced to remain loaded. Any assets that failed to patch may be left in an invalid state!

LogHttp: Warning: 000009A207B13200: request failed, libcurl error: 6 (Couldn’t resolve host name)

LogHotfixManager: Error: Only 156 of 158 assets were successfully patched from ‘AssetHotfix’ section in the Game .ini file. The patched assets will be forced to remain loaded. Any assets that failed to patch may be left in an invalid state!

LogValkyrieSyncProject: Error: Failed to initialize dependency modules: [Failed to resolve Game Feature Data for module [alcatraz]]

Above is the text in Red from Output Log.


Display Name

I think the material M_FlyingRinbow might have caused this to happen as everything was working fine up to that point unless I am unlucky and it is something else.
Please could someone try to help I would really appreciate it.

Thanks for any help / info with this, I will also try and report this bug through the Map Help option but don’t have an Island Code as the map is not yet published.

Thanks again


This is the map so far maybe at 70% first map I will publish in Fortnite UEFN if it’s possible to get it working again, I can still edit / make changes but can not launch a session so no way to test it out.

Will be 16 player Free For All

@Fallen-Champ Hello! This is something that our Player Support team can investigate for you to give more information: Epic Games Technical Support & Customer Service | Epic Games

1 Like

Thank you, I looked on the page with some fixes and updated / verified game files, also updated drivers and ran as administrator and had no luck so far.

On 4 days off tomorrow so will look further and see what other info is available.

1 Like

I updated my video card drivers and also did this - Repair Visual C++ Redistributables
Unfortunately nothing has changed I still get the failed to initialize dependency modules message on trying to launch the map. :frowning_face:

Unsure now if it is something server side where the maps are stored / hosted from or if it is something I can fix in the Unreal-FortniteEditor but would need some guidance to move forward on this as I am out of ideas.

Thank you for that link Stevie-Moon, where do I go next do I fill out a Support request?
I had gone into UEFN / Help / Report Issue and from there was taken to Creator Bug Report Form, I filled everything out except Island Code (unsure if I have an island code for my map or if I get given that after publishing, If I have one for a currently unpublished map I don’t know where to find that info at present.

I have not heard anything reference reporting the bug but understand these things will take time.
So anything else I can do or any info I should look at I am in limbo with this issue so would have to get some further help guidance.

Thanks in advance to anyone who can help.

On another post of the same issue it says this but this does not apply to my project so something else must be causing the problem.

Got that from another post found HERE
I can confirm my projects are stored on OneDrive but never had an issue previously the others launch fine and this one did for the last 6 - 8 weeks and only stopped working around 8th July.

Here is the latest info from Output Log

Sometimes I also get this - failed to create server session then when I try again it tries to launch but get the above (failed to initialize dependency module)

Map is almost finished just placing weapons & cover + tidying a few areas up, have no way of checking or publishing until I can launch the session.

UnrealEditorFortnite.log (13.3 MB)
Is this file of any use for this issue I am having?

In another post I have heard people ask for the uefnproject file for that project (unsure where to get that) & also the UEFN log when you get “Failed to initialize dependency modules” again unsure where to find these things.

The attachment to this post I got through Help / Report a problem, I copied to clipboard and believe this text doc is that info but unsure where to find the zip file mentioned in other posts, if there is anything else I can do at my end please let me know so I can get this file launching again, thanks.

Do you have an asset of type FortGameFeatureData named GameFeatureData at the root of your project?

Thank you for the reply Dave, my skills are quite limited with the folders and where things are located.

I looked in PC-Documents-Fortnite=Alcatraz-Projects-Plugins-Alcatraz-Content
The map is called Indominus but originally I had started an Alcatraz map so I will look at making Indominus the default map.

In this area - bigger image with the folders, lower down I can see this GameFeatureData.uasset (unsure if this is the one you mentioned)

The same as above GameFeatureData.uasset is listed in a folder I created for sequenced items.

Uploaded images of where I looked, the only folders I did not go through were in External Actors as there were so many in there.

screen grab from the sequences folder below

Also have Fortnite in Program Files x86
Unsure where to find the Root folder in the project - hoping it is from the images in this post as nothing says root - please can you point me in the right direction if it is located somewhere else.

I did a search and it shows up these 2 under that name, thats it

I did some more digging and ended up in this location, found a JSON file for INDOMINUS which is the map in question.

This was from another post I looked at reference a similar issue, opened it in a text editor but could not find the word bindings so thinking my problem is something different.

The GameFeatureData asset needs to be at the root of the Content folder (i.e. not in the sequences subfolder)
I suggest you never do any file operations directly in Windows Explorer (such as moving/copying uasset files) since you’re likely to break references between assets.
Do it from the UEFN content browser instead

Really sorry my knowledge is so limited thanks for hanging in there and helping.

Found it :smile: ng:

I managed to move the file in the end, now have some item references that do not exist so will remove those and hopefully the map will launch.

Guessing I did this when I created the sequences folder I must have moved that item which stopped the map from working so it wasn’t the Niagra effects after all.

Thanks for everything, fingers crossed this will work now.

It worked - really happy as I had been bogged down almost two weeks thinking I might lose the work put into this map.

Thanks so much for all your help, really appreciate it a lot - I got a happy ending YAY :+1: