Landscape shaders dont compile after adding additional Material Functions

Hey everyone,
I recently ran into a small problem, whenever I add additional material functions to the Landscape master material (The one applied on the landscape), the shaders dont compile and the default grey texture shows up. As im quite new to Unreal Engine 4, I followed a tutorial on how to import slope map through world machine to unreal, and it worked quite well. I will attach a screenshot of my landscape master material here. Seems more of a hardware limitation to me, if thats the cause is there any way around? Thanks.

Xeon W3550
R7 360 2GB

Landscape shaders can be a bit finicky if your texture count gets too high, I think if you have more than 6 or 8 (can’t remember which) different textures in your landscape material, you’ll run into compilation errors. You could do stuff like texture packing for spec maps to get around this, but it’s still a pretty hefty limitation.

Good luck!

Ive already figured out the problem, think it was due to using too many texture samples. Fixed it by changing most of texture samples to “Shared Wrap”. Dont know whats the difference tbh, except that it dosent use a sampler slot.