Landscape material Layers not showing up

Tried everything i could find online but my landscape material layers just wont show up
any ideas how to fix this?

2 Likes

https://docs.unrealengine.com/en-us/Engine/Landscape/QuickStart/5

Search for layer info here. You’ll see what to do.

So you hit the little plus button and it doesn’t have any options pop up? Or it appears to help you and then no layer info is created? Where does the problem occur, in other words?

Reinstall the engine as a last resort…! :stuck_out_tongue:

I followed this guide and applied the material the exact same way by still no layer info Showing, i even tried other landscape materials . it seems my engine is just broken some how

No layer info is created by engin so there is no plus button as shown on the screen cap there is no layers. no matter how i set up my material or how i apply it to my landscape.

so last resort seems to be my only option :confused:

Did reintall help? I have the same problem. I used 4.21, added 4.22 but it still does not work. Maybe deleting the whole thing would help… But not sure. Because i have an older project, where i have layered material and it still works.

first check your landscape gone balck ,if yes then your material is working carrectly .if not check your material.

Dude its simple your landscape material is not assigned do it manually by going to details tab of your landscape search for landscape material click and search for your material created and select this will apply your mat and it would also appear on your layers tab hope this thing works for you.

Hi,

I also faced this issue and solve it just by switching from Sculpt to Paint tab inside Landscape mode and all layers appeared as they should be :slight_smile:

I actually managed to know the problem, after about an hour of twisting and bending my eyes.

When you use a Layer Blend, the layer names will be set to “None” automatically by the engine, and they won’t appear in your Landscape Painter.

You have to click on “Layer Blend” and expand the layers and give them names, they will show up.

1
2

6 Likes

A problem from 2019 still exists today (2022) on UE5… I’m starting to wonder why I chose Unreal Engine to start a game project. I’m very upset, not only because of this problem, but many other issues that are entirely on the Editor side, basic things like that which doesn’t work correctly, and its making me waste a lot of days trying to fix those issues by looking for “Fixes” that looks like nobody knows how to fix.

Comparing with my time on Unity, I never had any problem with the editor itself.

1 Like

UPDATE -I fixed this issue when I save - quit -reload. I’m glad this bug hasn’t morphed beyond it’s original issues.

Alright, I still have this issue even though I renamed the layers and did the tricks to get the layers to load. I’ve been aware of this bug before, but doing the above steps have never failed me before now. I have just updated to UE5.0.3 - is this a new bug?

1 Like

Dude, i Know it may soud random but you a genius! :heart_hands:

OMG Thank you :slight_smile:

When I tried adding a new layer in the material, the layer didn’t appear in landscape paint and the solution was to click on apply in the material window (it is a bit to the left from the save icon)