Download

Landscape: Instanced meshes don't yet support unique static lighting for each LOD etc.

Hey all.
After a break I returned to UE4, and saw, that I needed to rebuild the lighting.
I just upgraded to 4.9 shootergame.
The build is fine, but it gives errors at the end.

Warning Hill Instanced meshes don’t yet support unique static lighting for each LOD, lighting on LOD 1+ may be incorrect

It only happens for my landscapes, and it writes the error many times foreach landscape I have.
I can’t find anything to fix it, and rebuilding doesn’t work.
Any help?

P.S I haven’t changed the landscape since 4.8.

1 Like

Hey,

I have the same Problem with 4.9. hope someone can help us.

Me too get 45 warnings like that after light building with a landscape that worked fine in 4.8.3

Yes, I’m having the same issue caused by the grass on my landscape… same messages… my lighting won’t even build

Same problem. Anybody figure it out yet?

I this even problem! and my build lighting remains of 0%

I have same problem :frowning:

UP please !

Same problem. 25 warnings. Really need help !

It’s just warning. Nothing that you can really do about it. Just wait that UE4 start to actually support that.

Well that’s just awesome…I need to make a forest scene for a teaser and none of my assets or marketplace stuff has been updated for 4.10 and really don’t have the room to make a new copy, install 4.10.1 and hope it works. This is a bit annoying…

the only answer can be found

LODs will not support unique lightmaps for them. They will use the lightmap from the base mesh, which depending on the changes for the lower LOD can cause lighting artifacts.
https://answers.unrealengine.com/questions/343146/landscape-error-after-build-in-lighting-results.html

All right. But concretely what should be done to go further (and have a correct shading calculation) Thank you. have a nice day.

G
M
T

[TABLE=“cellspacing: 1”]

	Détecter la langueAfrikaansAlbanaisAllemandAnglaisArabeArménienAzériBasqueBengaliBiélorusseBirmanBosniaqueBulgareCatalanCebuanoChichewaChinois (Simp)Chinois (Trad)CingalaiCoréenCréole haïtienCroateDanoisEspagnolEspérantoEstonienFinnoisFrançaisGalicienGalloisGéorgienGoudjaratiGrecHaoussaHébreuHindiHmongHongroisIgboIndonésienIrlandaisIslandaisItalienJaponaisJavanaisKannadaKazakhKhmerLaotienLatinLettonLituanienMacédonienMalaisienMalayalamMalgacheMaltaisMaoriMarathiMongolNéerlandaisNépalaisNorvégienOuzbekPanjabiPersanPolonaisPortugaisRoumainRusseSerbeSesothoSlovaqueSlovèneSomaliSoudanaisSuédoisSwahiliTadjikTagalogTamoulTchèqueTeluguThaïTurcUkrainienUrduVietnamienYiddishYoroubaZoulou
	 		 
	
	AfrikaansAlbanaisAllemandAnglaisArabeArménienAzériBasqueBengaliBiélorusseBirmanBosniaqueBulgareCatalanCebuanoChichewaChinois (Simp)Chinois (Trad)CingalaiCoréenCréole haïtienCroateDanoisEspagnolEspérantoEstonienFinnoisFrançaisGalicienGalloisGéorgienGoudjaratiGrecHaoussaHébreuHindiHmongHongroisIgboIndonésienIrlandaisIslandaisItalienJaponaisJavanaisKannadaKazakhKhmerLaotienLatinLettonLituanienMacédonienMalaisienMalayalamMalgacheMaltaisMaoriMarathiMongolNéerlandaisNépalaisNorvégienOuzbekPanjabiPersanPolonaisPortugaisRoumainRusseSerbeSesothoSlovaqueSlovèneSomaliSoudanaisSuédoisSwahiliTadjikTagalogTamoulTchèqueTeluguThaïTurcUkrainienUrduVietnamienYiddishYoroubaZoulou

Fonction Sound est limitée à 200 caractères

[TABLE]

	[Options](https://forums.unrealengine.com/core/moz-extension://c6adb48a-5786-4cd0-b9ae-2ae96a66cf19/content/html/options/options.html?bbl) : [Historique](https://forums.unrealengine.com/core/moz-extension://c6adb48a-5786-4cd0-b9ae-2ae96a66cf19/content/html/options/options.html?hist) : [Commentaires](https://forums.unrealengine.com/core/moz-extension://c6adb48a-5786-4cd0-b9ae-2ae96a66cf19/content/html/options/options.html?feed) : [Donate](https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=GD9D8CPW8HFA2)
	Fermer

2018 year all the same mistake

ok so i have just successfully got my error to go away for me i went inside my landscape material and hit apply to rebuild it and mine went away .if your apply button is dark and you cant click it grab a node and move it and then hit apply it will rebuild the error will go away your welcome

I am glad that worked for you. I know it’s only a warning and I think I know how to get rid of it, just have not tried it yet, but your method did not work for me.If there is a fix it will be in the lightmaps like it suggests. I am going to look into rebuilding the lightmaps before I rebuild the scene lighting. Make sure it understands to use the same UV for lighting.

That didn’t work for me. However, when I remove the foliage from the foliage library the error disappeared.

Unfortunately didn’t worked for me. Then I’ve tried to clear every landscape layer and relaunch engine with administrator privileges and problem is gone. I can’t determine what exactly was the solution but maybe somebody will find this useful.

Btw, error messages (Instanced meshes don’t yet support unique static lighting for each LOD etc.) are still in the message log under “Lighting results”, but lights building goes without failure now.

P.s. Problem appeared after I’ve changed landscape Section Size

Hey! Just fixed this by opening up each static mesh in my landscape and switching the LOD group to ‘Foliage’

1 Like

to solve this problem, just enter the mesh which is a sheet, go to LOD Settings and in LOD Group change from none to Foliage.

1 Like