IV-CMD-DREQ - This content requires a supported Engine version to be installed. UE5 on Mac


I am getting this error when trying to create the City Sample demo for UE5 on my computer - IV-CMD-DREQ - This content requires a supported Engine version to be installed. Please
check product details for supported Engine versions.

I am running the latest release of UE5 on Mac OS Monterey 12.3 on a M1 Max MacBook.
Does anyone know why this is happening and what I could do? It also happens when I tried to add the city buildings samples to a project I have created in UE5.


Another person has this issue and is on a MacBook… Meerkat demo incompatible UE version

Am having same issue as bobbygeorge. Am also on MacBook Pro M1 Max, Monterey 12.3.1. Any suggestions?



Same here - trying to install SLAY ANIMATION SAMPLE on Macbook M1 Pro.


Аs someone mentioned to me on another forum, many projects are only available for Windows and are not compatible for Mac. Epic needs to make them available for Mac with appropriate changes.


Ah ok. I see then. I was wondering why it was only macs…

I don’t why UE5 officially launch for mac if half the things just not work and crash become the ultimatie feature of the unreal engine 5. if the product is not usable then how can we go creative? what is the meaning of 16,000+ assets if my Meta-Human character is not having groom hairs in my short film? Should i show them as blad head in whole short film? answer me unreal engine 5 team? answer me…

Hire good IT engineers. Some employees are not working good enough that’s the reason groom hair is not working in mac. Fix the hair on immdeiate basis and fix all other bugs. Work 16 hours a day if you had to but fix groom hairs. Not matter what.

Next release should fix everthing. Anything works on windows should also work mac. i think everthing is clear.

it isn’t only macs, I am getting it on windwos 10 today

1 Like

hi, @bobbygeorgiev @Unrealgeek24,

The screenshot shows you are using an old version of UE5.

The current version of UE 5.0.2 is the ONLY version I know which will load Slayer or the new Content Valley of Ancient and new City now work. Go to the Epic Launcher → settings then click Update and restart. Now look at the Unreal 5 installation icon and click drop down click install updated and when finished the Launch icon should display at least 5.0.2