Is there any way to disable self-shadowing?

I have a static mesh which I want to disable the self-shadowing on, problem is that I want it to still have shading and I still want it to cast/receive shadows on/from other objects. (So an unlit material will not work) I just do not want it to cast a self-shadow. I see in the details panel there is a way to enable only self shadowing, but that’s the opposite of what I am looking for.

Is there any way to achieve this?

I got a little confused, man…

If you just don´t want it to cast a shadow, just disable: “Cast Shadow”…

or is it the opposite? Cast but not receive?

Please explain

I ONLY want to disable self-shadowing, I want all other shadowing to work as expected.

Disabling cast shadows will not work, because although that will prevent the object from self shadowing, it also prevents it from casting shadows on anything else. Which is not what I want.

I want it to receive shadows from other objects, I want it to cast shadows on other objects, the only thing that I don’t want is self-shadowing.

If your light source mesh can fit in a sphere or capsule then you can use the “Source Radius” and “Source Length” parameters to tell UE4 at what distance to begin ‘casting’ the light. That will solve your problem for the most part,.

AFAIK self shadowing cannot be disabled. You’ll need to workaround it by using a multiply of you base color plugged into the emissive input. Use a low value for the multiply so that it’s just enough to crush the self shadowing that happens.