Download

iOS Deployment Failed! HELP needed by STAFF

Hello, I really need help with a problem I am facing when deploying my game to my iPhone. I have set my Bundle ID exactly how I set it in the Apple Developer program (I used explicit ID since I need gamecenter for the game), and it still did not work, I am getting these errors:

  • LogPlayLevel: [DD] … Error: Failed to connect to bundle
  • LogPlayLevel: IPP ERROR: Application exception: System.Security.Cryptography.CryptographicException: Invalid provider type specified.
  • LogPlayLevel: ERROR: Command failed (Result:1): D:\Program Files\Epic Games\UE4\UE_4.18\Engine\Binaries\DotNET\IOS\IPhonePackager.exe RepackageFromStage “Engine” -config Development -schemename UE4 -schemeconfig “Development” -sign -stagedir
  • LogPlayLevel: ERROR: Command failed (Result:1): D:\Program Files\Epic Games\UE4\UE_4.18\Engine\Binaries\DotNET\IOS\IPhonePackager.exe RepackageFromStage “Engine” -config Development -schemename UE4 -schemeconfig “Development” -sign -stagedir

Thanks

Apparently you didnt follow UE4 guidelines if you have this error.
D:\Program Files\Epic Games\UE4\UE_4.18\Engine\Binaries\DotNET\IOS\IPhonePackager.exe
try these for help.

https://www.youtube.com/watch?v=Z6FAl6v0ax0&t=216s

I followed it step by step, but instead of a WildCard ID I used a Explicit ID because I will need GameCenter in my game. Does anybody know the answer to this ?

Can someone help I am strict within a time constrait!

Your cerificates should turn green. The 2 links that I gave you work every single time I go through them, and build.
There isnt a secret. Start off with Ue4 iphonepackager.exe not “APPLE” when your mobile provision, and certs turn green you can launch to device.
Explicit ID, or wildcard ID doesnt matter if you type it in right. If it’s yellow. It’s not right…

I know I went through them and both of them are green and stil not working.Which version of UE4 are you running?

I’ve built to an ios device from 4.14 up to 4.17. It isn’t UE4.
Delete all your mobile provisions in apple dev account, and start from scratch with UE4 iphonepackager.exe not “APPLE”.
You dont start with apple. Did you upload your ue4 key to apple dev.com first? Step by step it works everytime for me.
It’s lemony snickett if you don’t do it in the right sequence.

Ok I will install 4.17, since I am using 4.18 and start from scratch and we’ll see what happens :slight_smile:

I have already installed 4.17, but I have a strange thing where whenever I create a new certificate, UE4 will consider it unvalid, until the next day.

Hi BillBeob,
I might be having a similar problem.

I created a new certificate and a new provisioning profile. Now when I import them to Unreal Engine I get this red written message on the status part of my provision “No Valid Certificate Found”.
I tried creating them at least 5 times. And still the same error. It was working fine before…

So will that Certificate be valid in a day or so???

I’m also including a screenshot of my provision settings.

NOT WORKING! This is really frustrating, I am here to develop games and not to resolve bugs within the software, it is destroying my workflow. I am getting the same bugs even after downloading 4.17.2. I am going to list the steps that I am going through so you can make sure that I am doing the right thing:

  1. Open IPHONEPACKAGER.EXE
  2. Browse to the UE4 project file
  3. Click create certificate request and key pair
  4. Type in my email adress
  5. My common name
  6. Hit generate key pair and save it
  7. Generate CSR
  8. Now I would login into my Apple Developer account and create a certificate using the CSR generated from the IPHONEPACKAGER.EXE
  9. Add my Device’s UDID
  10. Make an App ID and use an explicit App ID (I even tried Bundle ID and did not work same errors), (I tried com.epicgames.myproject, com.myproject, myproject and others and all did not work)
  11. Make a mobile provision using the App ID and device UDID and certificate made
  12. Open UE4, go to project settings, iOS, and import the mobile provision and Apple certificate (I even tried using the IPHONEPACKAGER.EXE to import them but it tells me that the info.plist is unavaialble, even Epic said that IPHONEPACKAGER.EXE is just left as a legacy as some features stopped working)
  13. Type in my Bundle Identifier
  14. The mobile provision and certificate would turn green, indicating validity
  15. Launch the project to All_iOS_on Desktop
  16. Then the most frustrating part (Launch Failed, the errors are listed above. I tried the Sample projects, UE4 4.18.1, UE4 4.18.2, UE4 4.17.2 and different App ID’s NON ARE WORKING).

*Note; Everything generated on the Apple Developer website was set to development and not distribution.

Anybody’s help is really appreciated, especially the UE4 Staff.

Does the App ID have to be a registered domain? I heard from some users that they had success with that. If that is the case why isn’t (com.epicgames.myproject) working?

I have just downloaded UE4 4.16.3 and a firewall notice popped up asking me wether to set it to private or public, I set to private thinking that I finally found a solution to the errors. BUT NOPE, after a long wait of hope, the launching failed with the same error. I am in need of assistance please, whoever has knowledge in regards to this, suggest some solutions :slight_smile:

Just to note I am using Windows, as UE4 says you can launch to an iOS device using Windows, but for the final build you need a Mac, am I missing something?

I had the same problem and I created new sample app in Xcode, launched it to device and then tried in UE4 with the same package name and it worked!

Hello, I was using a friend’s Mac this whole day, I tried what gameDna informed me, I made a sample single page app on Xcode and then deployed it on my iPhone and it I saw it on the homescreen. So I went back to my Windows PC and tried deploying the game with the same package name but did not work:( Same errors. Do I have to do anything special I feel that I missed something.

Can you please give me more info on what you told me to do, becuase I am left with many questions. Does the app in Xcode have to have the same provision as the game in UE4?

I was having a look over the info.plist and I found this:

    <key>CFBundleURLName</key>
    <string>com.Epic.Unreal</string>

Does this affect me in any way, I tried changing it to my bundle id but it kept reverting back after launching, is this causing the errors?

I am honestly hopeless now, my game is %80 complete in terms of logic and design and I can not go anywhere with it, wow!

If your bundle name isnt right you cant launch to device.
The steps work for me everytime I do them in sequence.
I’ve had issues typing in the Bundle Id.
Whenever I have issue I go to apple dev, and restart by giving Apple the ue4 keys.
Make sure your device assigned is listed as the one your using for dev.

Yes, in Xcode it should have the same provision as in UE4. Make new app in Xcode with the same bundle/package name as in UE4, export provisioning profiles from Xcode, certificates from Keychain Access, and then import these files to your UE4 project.

I finaly feel that we are getting somewhere, I done what gameDNA told me and one of the errors stopped appearing (the failed to connect to bundle one), but the others are still coming:

  • LogPlayLevel: IPhonePackager: IPP ERROR: Application exception: System.Security.Cryptography.CryptographicException: Invalid provider type specified.
  • LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.CommandUtils+CommandFailedException: Command failed (Result:1): D:\Program Files\Epic Games\UE4\UE_4.17\Engine\Binaries\DotNET\IOS\IPhonePackager.exe RepackageFromStage “Engine” -config Development -schemename UE4 -schemeconfig “Development” -sign -stagedir
  • PackagingResults: Error: Deployment failed! Unknown Error