Download

iOS Deployment Failed! HELP needed by STAFF

Do you know the solution to these? (I found the solutions, look on the post underneath)

Ok, after some fiddling around I solved most of the above issues, but now a new issue came up. These are the errors now:

  • LogPlayLevel: DeploymentServer: Install \ Update of “myproject.ipa” failed with Unknown error 0xE8000087 in 14.54 seconds
  • LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.CommandUtils+CommandFailedException: Command failed (Result:1): D:\Program Files\Epic Games\UE4\UE_4.17\Engine\Binaries\DotNET\IOS\DeploymentServer.exe Install -ipa
  • PackagingResults: Error: Deployment failed! Unknown Error

It seems like I won’t finish from this until I face all the launching bugs in the software.

FINALLY, I GOT IT TO WORK ON UE4 4.16.3, THANK YOU THADKINSJR AND GAMEDNA STUDIO.

I just have on more question, since the iphonepackager.exe on 4.16.3 is working I copied it to the 4.17.2 one, but the 4.1.7.2 build still did not work, is there a way I can fix that because the 4.1.6.3 packager is working fine, but I am hoping I can move it to 4.17.2 to make that version work. Do I only move the .exe or the other files in the IOS folder as well?

I don’t think you have to move anything. Either you have the keys or you dont. I havent had problems upgrading the engine. I usually just install the next ver. then test, and delete. The keys, and provisions usually move from one to the other, but I don’t get both apps on my device.

Does anyone develop on macOS here, cause all these problems seem to be windows users. I am having issues within MacOS

Hi Asquires2002,
Although I am using a Windows PC for development, I have gained some experience when using a Mac previosly. Here are some tips:

  1. Make sure the project Bundle ID (Settings>Project Settings>iOS) matches the provision created in the Apple Developer portal.

  2. When creating certificates, firstly, go to KeyChain Access, then Request a sample certificate. After filling in email and name, you save the .csr file onto your desktop. And through that you will also have a public and private .p12 key in your “keys” in KeyChain Access. Now go to the Apple Developer Portal and request a iOS development certificate, it will ask you for a .csr file, use the one saved on your desktop.

  3. As suggested by “gameDNA”, create a sample single page app in XCode, and make sure the Bundle ID also matches, however, before creating a sample project you make sure all the development provisions, App IDs, Certificates, and Devices are already set up in the Apple Developer Portal. After setting up these you download the provision and the certificate and import them into KeyChain Access (by double clicking on them). Then you deploy the app to your testing device. Note: The sample app must have the same name as the app in UE4, have the same Bundle ID, and use the same provisions and certificates.

  4. Before hopping onto UE4, you must go to your KeyChain Access and browse for the certificate that you have imported recently, right click on it and click “Export…”, it will ask you type in a password, do not type in anything leave it empty. This will save a file called “Certificates”. So now we have our Apple development certificate (From Apple Developer Portal), generally called “ios_development.cer”, a file called “Certificates.p12” (That we have just exported) containing a public and private key, and our App Provision (From Apple Developer Portal). Now hop onto UE4 and import these files through going to (Settings>Project Settings>iOS), import the “ios_developement.cer” then it will ask you for the “keys” that you used to make the cerificate, browse to the “certificates.p12” and import that. Import the App Provision and you should be good to go, remember you MUST have a matching Bundle ID.

Try these and inform me what happens.

Thanks

Hi BillBeob, I too am on macOs and have the same problem as the OP.
My additional problem is that my Developer Account is a University one, meaning I don’t have the privileges to create AppIds, provisioning Files and Registering Devices at my own discretion.
After contacting the Responsible I managed to get my devices registered, a certificate created, and a provisioning file as well but with the WILDCARD " * " as AppId.
On Xcode everything works fine as it is automatic. I was able to deploy a test app on my iPhone pretty easily.
On Unreal instead I get the errors everyone here is getting. Moreover while going through your points I get stuck at number one because I don’t know what to put as a bundle ID considering " * " are not allowed in the field.
What can I do?
I hope you can help me,
Thank you

EDIT

I still don’t know how but i managed to get it working…somehow.

  • My Responsible gave me the provisioning file he created, I double clicked it. Nothing happened but I’m sure it got installed somewhere.
  • I created a single page app as suggested (probably the most crucial thing), and set the bundle with my university URL, (eg: com.myuniversity.myapp). I don’t know if using an existing url really made the trick. In future I’ll try using something else.
  • Made sure to set the same bundle id in Unreal
  • always in unreal I selected the provisioning file previously installed . I have a tons of them now, some automatic from UE , others I don’t have idea where they are from. anyways, selecting the one I installed got rid of this topic’s OP error which i was getting as well.
  • installed and run the app from Xcode
  • Made sure to keep the iPhone unlocked through the whole process

and SUCCESS!

EDIT2

I tried again with ARSample project downloadable from Unreal, no side app on Xcode needed, just put com.myuniversity.myapp as bundle id and selected my provisioning file previously installed. In the log I still see the system trying with a combination of apps and provisioning files , I even spotted the name of my previous Unreal Project used in the first edit, anyways I probably don’t understand what’s going on XD

I wrote this on another post, but this is what worked for me. I am on a Mac not a PC but it may be the same issue. Perhaps this is totally obvious to everyone but me and that’s why nobody is saying anything about it. In the bundle identifier I used [PROJECT_NAME] it never worked till I scrolled down to the Build section in Project Settings and checked Automatic Signing, then under that in the IOS Team ID I Logged in to Apple’s Developer Center, clicked on Account, Then Membership. Under Membership Information, I copied the Team ID and pasted that into the IOS Team ID field. Then it Deployed. Hope that helps someone.

Is this a development profile or adhoc?

If anyone is still having issues launching your iOS game on your device, you can try the following:

  1. Use the “IPhonePackager.exe” only to generate the “Certificate Signing Request” (It seems that after UE4.5 Epic deprecated its usage)
  • If you really want to use “IPhonePackager.exe”, you have to download a file called “UE4Game-Info.plist” from the 4.6 branch of UE4 in github and place it in your UE4 installation directory under: “UnrealEngine/Engine/Build/IOS/”. If you don’t do so, you will get errors on the IPhonePackager console.
  1. Remove all obsolete provisioning profiles from your project - Remove obsolete mobileprovision profiles
  2. Remove all your certificates from your project (not quite sure how I did that, because it was a while ago)
  3. Reboot your PC and verify that you don’t have any provisioning profiles or certificates in your iOS settings of your UE4 project
  4. Go to your apple developer console and remove all Certificates, Identifiers and Profiles
  5. Follow the official iOS provisioning guide from Epic
  • Important information about the identifiers step:

    My **identifier** in the apple console is using a wildcard and it is: **com.mycompany.***
    The **bundle identifier** in iOS project settings is: **com.mycompany.mygame**
    
  1. My certificate did not work right away. I had to wait for a few hours
  2. I was not able to launch the game on my iOS device, so I had to first package it and upload the .IPA file to my iPhone via “IPhonePackager.exe” Advanced Tools Tab.