Intense lag when clicking the menu bar? 5.0.3

So for some reason, if I select
any of the options such as File or Edit in the menu bar, this includes the ellipsis to change which play mode, it instantly stops the moment I can get the tab closed but it’s very very laggy and oddly makes any active Discord call go completely silent until I leave and re-join the call.

I would also like to update this to state that this is actually for any button that presents a pop-up. This makes it almost unusable to work with.

Do you experience any other lag when using the engine, or only when interacting with the game menus? What PC hardware are you running: GPU, CPU and RAM amount?

nope no other lag. It’s more like a freeze when it happens. I just opened a project and for about 2 minutes it worked fine but it’s doing it again. At first I thought it was something to with Discord but on trying to replicate this with task manager open and unreal in windowed mode, it seems like it occurs only when Unreal is fullscreen. I can take a screen recording and show but it basically goes to like a frame every 5 seconds for no apparent reason. My hardware should absolutely be able to power this without issues so I’m certain its not that. GPU AMD RX 6700 TX. CPU AMD Ryzen 5 2600 Six-Core Processor 3400mhz. RAM is 16 GB.

Here’s a clip of it occurring. I’m not sure if this is worth noting but there’s a faint buzz from my PC whenever the project is open in windowed or full-screen with the buzz getting slightly lower and higherpitched in fullscreen compared to windowed. The buzz cuts out the moment I select a menu/tab like this. When the project is minimised, the sound is not made. I ave had a potentially related issue before when playing 1 video game where if I was in a voice call, playing the game and using Bluetooth headphones if the headphones disconnected, my game would freeze or stutter. I don’t think this is related though but the discord audio issue seems bizarre.

1 Like

I’m experiencing the exact same issue. My computer should be able to run the program no problem, as it handles other programs doing more, without any issue. It’s just the menu bar that causes insane lag. I have tried 5.1 and 5.0.3, reinstalled both the Epic Games launcher and Unreal Engine itself. No clue where the issue stems from.

1 Like

I also have the same problem here
the thing is it was working pretty well last week
the thing is this only happens on full screen
i mean this happens only when u maximize the unreal engine window
you could just exit the maximize window and stretch it and it is okay
i think there is something wrong with windows 11

I have the exact same problem and can confirm its not just a windows 11 thing, I’m running windows 10 and it still happens. The issue started for me when I updated to 5.0.3. I then updated to 5.1 and it persisted. I updated AMD graphics drivers to the most recent 22.11, still happened. Downgraded graphics drivers to 22.5, still happened. Tomorrow I will install unreal 4.27 or whatever the most recent 4.x version is at this point and see if it happens there to. If I still feel up for it I may swap out my RX 6700 XT for my GTX 970 and see if it happens on that too. At this point it seems to be an Unreal Engine problem, not an OS problem or a graphics card/driver problem. Hopefully we can narrow this down and get a fix soon.

OS: Windows 10
CPU: Ryzen 5 3600 CPU
GPU: RX 6700 XT
RAM: Crucial Ballistix 2x8 GB 3600 MHz RAM (underclocked to 3200 mhz)
MB: ASRock B550 Phantom Gaming 4ac
PSU: AresGame 850W Gold

Okay, so I tested this last night with UE 4.27.2 and it isn’t a problem there. So so far it’s looking like its isolated to the newer UE5 versions. Also, I swapped out my RX 6700 XT for my GTX 970 and the problem didn’t happen with that card, so it seems like this is an AMD only problem. For now the best workaround seems to be what @Ahivo suggested and just to stretch the small window to fill the majority of the screen until this problem gets properly fixed by the devs.

Hey friends, to confirm this is happening to me too :frowning: … I bought this laptop to start learning unreal not a week ago, not the most performing laptop, but it should do the job. Installed Unreal 5.1.0 and been working in it for the past 3 days with no issues whatsoever, just doing tutorials, so far so good… and today, it starting doing that lag on the menu tabs. Tried many solutions advertised but the one from @Ahivo did the trick for me. How do we know Epic devs have visibility on this? Any way to tag them or open a case ticket? Thank you all and thank you for the solution, it was so frustrating, and I was having so much fun learning when this thing happened. Thanks again!

OS: Windows 11
CPU: AMD Ryzen 7 6800H CPU
GPU: RTX 3060
RAM: 16 GB

I have the same issue. I also have an amd card… I’m guessing it’s a issue there seeing your responses.

hey guys. I have the same issue and yes only maximize ue windows. But this started when i got new 165hz monitor (old one is 60hz general monitor).

Same problem here.
AMD Ryzen 5 5600X 6-Core Processor 3.70 GHz
RAM 20,0 GBs
Win10 64

All works fine until I’m trying to use upper menus (file, edit, etc…). At the moment before appearance of menu a freeze happens: stops all system: mouse movements, sound, etc for like 10 seconds.
If i have some application which can use ‘always on top’ mode (like mplayer or pureref) - lag do not occurs.
Updating GPU drivers and UE to 5.1.1 version didn’t fix the problem.

I have a Radeon 6800XT and was also getting this issue. A different post mentioned turning off auto hide and it worked for me.

1 Like

I have auto-hide on too so this could be part of the problem. For now I’ve just been using Unreal in windowed mode which fixes it but hopefully this solves it too for anyone else.

Same problem, if I dock my pop up windows to the main unreal interface I don’t experience any stuttering or lag but anytime I have a separate window I have extreme performance loss.

|Processor|AMD Ryzen 9 6900HX with Radeon Graphics 3.29 GHz|
|Installed RAM|16.0 GB (15.2 GB usable)|
|Device ID|2B113502-2190-47CA-A732-E0D0299F40FB|
|Product ID|00342-20967-71365-AAOEM|
|System type|64-bit operating system, x64-based processor|

Possible solution for Windows + AMD

If you have your Windows taskbar auto-hide enabled, then you should disable it.

This have fixed the problem for me.


I get the same issue, also using an AMD RX 6700 XT. The entire computer freezes for a second or two, including the cursor and audio. I almost expect a blue screen to happen, but it recovers and starts rendering a few frames per second until the offending menu is closed. It seems like this must be a driver or hardware issue, so probably something more to taken up with AMD. Hopefully it can be fixed either way. Keeping the application in windowed mode works as a workaround, as does disabling auto-hide on the windows taskbar as @Low.key.Me mentioned.

disabling auto-hide worked for me

Fun thing it is 2023 and it is still an issue in 5.2.1 with AMD gpu on Win10.
Switching off AutoHide for Task bar worked. Thanks a lot.

1 Like