Indirect Lighting without coloring

The lighting is white.

Because of the indirect lighting, the white cube and the white object overhead (see picture) turn green.

I want the indirect lighting to be completely neutral so that the cube is white.

A similar question was answered here, but it doesn’t seem to work for me:

So, like in this answer suggested, the Diffuse Boosts of the materials are set to 0.
If i set the Diffuse Boost in the world settings to 0, everything will be black. Changing the “Environment Intensity” seems to do nothing.

Meanwhile I fixed the problem.
The technical term of this coloring is “Color Bleeding”

What I searched for was the GI Replace node in the material editor.