Indirect Light Leakage

I’m experimenting with lightmass and the static GI, and I’ve noticed that when I put together Wall SMs inside UE4, the indirect light bounces ignore the physical obstruction of the wall and leak behind it.

Though the problem is subtle in well lit areas, it is very jarring in dark spots. (See pic)

The wall here is attached below the floor.

So is there a fix for it in UE4, or do I have edit the Static meshes to join them and maybe design the complete environment in 3ds Max???

P.S. - I need accurate lighting behavior for ArchVIZ

Hey Lycan,

Indirect lighting, as its name implies, illuminates areas that are not directly affected by lights. For instance, if you took a flashlight in a dark room and shown it at, lets say a desk, then the indirect light would still allow for you to see under that desk.

To disable the indirect lighting. Under the details panel of your light go to your Indirect Lighting Intensity and change that to 0.0. Then rebuild your lighting. This will disable the indirect lighting. It will just appear much less natural.

Here is a link to our documentation on lighting. I recommend going through it to tweak your lights to what you would like to see.

Thanks,
Logan