Incorrect Shadows on Mesh - Shadows or AO Issue?

When i build my scene i get these weird shadow or AO issues.All my textures are 4096 and all the lightmaps resolutions for the meshes are at 120.There is one directional light in the scene.I can’t seem to figure out what the issue is

Hi El Marz,

There are a couple of things we can check to see what’s going on here.

Can you post a screenshot of your Lightmap UV from the Mesh Editor. Toggle the UV button on the toolbar. Then from the drop down next to it change the UV to UV Channel 1. A screenshot from this would be helpful.

Also, when you set lightmap resolution it is best to use a power of two for the resolution (ie. 32, 64, 128, 256, etc).

With the directional light, is that set to the default of Stationary?

Thank you!


Hi Tim,

The light is set to Stationary.I just switched all of the lightmap resolutions to 128.
I tried to have a look at my lightmap density and my whole scene seems to be covered in an army green color.Is this normal?Btw, i am using a VR template that i found online (VR Game Template - XR Development - Epic Developer Community Forums) I don’t know if that would make a difference.Thank you in advance,


The screenshots didn’t attach for some reason

Hi Elbert,

The “Army Green” color is a known issue that happens with Lightmaps generated with the new auto-generated lightmaps feature.

I must say, I’m a little confused on my end. The two images you linked are of different selected items. Are the ones with the house or the ground mesh giving you the shadow issue? The second image looks like a ground mesh, which would probably need to have its lightmap resolution set to a higher value to get better shadow quality. Depending on the size it was scaled to, you may need to set it at 256, 512, or 1024. I would test these settings and build lighting.

To go back to the house. Is that a single plane with a texture applied but not other geometry detail?



Hi Tim,

Apologies for causing the confusion.With the first image I was just trying to show the lightmap density issue.The house geometries in the first images just has a detailed texture applied to it.However,there is separate Geometry attached to the facade of the building.For instance the windows ,the door frames e.t.c.
You mentioned scaling the UV’s.Mine are all at 4k.the same as the textures.Maybe that is the issue.I attached another image where you can see the simple building geometry more clearly.Thank you


There are a couple more things we can look at. If this doesn’t work you would mind attaching your asset. I wouldn’t need the textures just the mesh(s) that are causing the shadowing issue. Before it comes to that please try the following:

In your image details panel for the static mesh pictured above to go the tab that says Static Mesh Settings. always use a power of two for the LM resolution (Ie. 32, 64, 128, 256, 512, 1024, etc). For simple geometry having something in the range of 1024 is a bit overkill. Needing something more than 64 or 128 should not be needed.

Under the same tab hit the drop down arrow for advanced settings and check the lightmap coordinate index is set to 1 and not 0. If it’ 0 this could be the issue that’s being caused.

For the ground mesh using higher LM resolution is understandable because you need better shadows for the surface resolution.

When you bake lighting again, try doing so with a simple material applied to all meshes that is white. This will let us see the shading on the mesh specifically without the distraction of the material.

Let me know how it goes! :slight_smile: