Download

Impossible to have my material well displayed ...

Hello everyone !

I’m trying hard to make a good scene with the new Quixel Megascans library ! I’ve downloaded a few assets and materials from their library and I’m beggining the creation of a scene to test eveyrthing in 4k :slight_smile:

But I’m having a hard time to deal with the assets… I’ve tried to build a material for each asset (mostly rocks and branches etc) but the end result is always a dirty uniform color like brown … The normal map, the roughness etc seems to be good but the albedo of the asset is always lost in the final rendering I don’t know why … Can you help me ? I’m a begginer with materials , I succeed with the ground materials from Megascans but I can’t have any decent rendering with the assets …

As you can see I have several maps for this asset :

  • 1 Albedo map
  • 1 Bump map
  • 1 Displacement map
  • 1 Fuzz map (do you have a tutorial on how display this kind of maps ? don’t know how to deal with this !)
  • 1 Normal map
  • 1 Normal Bump map
  • 1 Roughness map
  • 1 Spec map

Why my end result is this awful brown uniform color ? My albedo is well connected on “Base color” why it does not display the real texture ? It’s odd because the normal map and the roughness seem to work …

879c769ff1005700bdda6fe994c73828132e3e87.jpeg

5402ea9a8286e69fba2622394d4a059d8c6c8ea9.jpeg

“Bump,” “Displacement,” “Normal,” and “Normal Bump” are all inherently the same kind of map.

Hello :wink:

I’ve connected only the displacement and the normal map , do you think is why I don’t have my albedo displayed on the asset ? Because I should be able to connect a lot of maps and , at least, have the albedo displayed no ?

Your Base Color is hooked up, and that’s the Albedo input.
Is your texture coordinate set correct?
I’d map a simple resolution 256 map with 16x16 black/white squares onto the mesh, to make sure the texture coordinates aren’t horribly stretched.

Other things to look at:
Is your normal map sampler set to “Normal” map type?
Your ambient occlusion looks very dark.

To me it looks like your UVs aren’t setup correctly…

I’ve broke the links of the channels of my material to try to put a uv checker on my asset to see if there is a kind of deformation , and here what I have with this setup . So everything seems to be waaaaaaaaay to stretched up … but I don’t know why because their assets seem to be already unwrapped … I tried to put a texture coordonate node to scale my UV checker on it and everytime I had just a uniform color depending on the numbers I’ve added in the material UT and IV tilling part . I’ve also tried to Mirror U and V but did not change anything …
The normal map is correctly set as normal in the sampler type . Yep the AO seems to be a bit dark I agree.

I’ve opened the .fbx file in 3ds MAX and open the UV editor by adding a unwrapper modifier just to check and the asset is unwrapped correctly , so strange ! It’s coming from something I did not set correctly in UE4 for sure !

22cff0e4ba60d1967160005a2ec58ff645568b61.jpeg

e00224497ee0788a9fddfbb9826a279992909eab.jpeg

I am running into the same problem with the materials for the meshes. Really wish there was documentation on setting up the shaders for megascans!

Check the UVs within UE4, using the static mesh editor.

-double post-

Hey, I have the same problem with the UVs of the Megascans in UE 4.13… somehow the UVs are not imported, i guess they will fix it in 4.13.1. To fix the problem you could import the mesh in Maya and export it again to UE.
For the Fuzzmap I use this simple setup:


hope it helps.

Make sure you don’t let UE4 make the UVs. I’m thinking that is what is going on. Check the UVs like ZacD said and it will tell you for sure.

@geylangwarrior : yeah they never have a decent documentation for their tools … It was also the case for Quixel DDO & NDO when it came out …
@ZacD : do you mean the static mesh editor like in the first screenshot in my first post ? The engine lag like crazy when I click on " show UV" and it does not show anything …
@James_Gallagher : The static editor is it like in my first screenshot ? because it seems that I was in the right place , but nothing shows up when I click on the uv editor :confused:

Sanity check - I noticed right away that your mesh is 1 million polygons - did you accidentally input the high poly model into Unreal? That would explain the lack of UVs, and the texture stretching.

@Delighte : Thanks for the fuzzmap setup and your advice ! I will export it again with 3ds max and it should work !
[MENTION=2791]James Steininger[/MENTION]: holy sh*t … That’s why … I miss clicked and imported the highpoly and the lod 0 but only worked on the wrong one … the highpoly one … omg … I will see if the problem is still her with the LOD 0 !

Hello again !

I replaced the high poly with the lod 0 and yes it’s way faster to compile shaders and stuff … BUT I have nothing display … I imported the lod 0 in 3dsMax , I’ve put the modifier unwarap uvw , everything seemed to be ok and I collapsed everything and exported everything. And did not changed nothing … Now the material is just black and I have 0 UV displayed in the static mesh editor …

50995c139e06bc5bb4c896c8f5bc0de4faff2d9f.jpeg

Maybe you can try it with Maya? Just import the megascans fbx into Maya and then just export it as an fbx again. I tested it out with different FBX-Exports: 2013/15/17 and it worked for me…

Here the default import with MegascansBridge:

and here the version with the Maya export:

I found a post about your problem with Max:
https://answers.unrealengine.com/questions/480957/uvs-not-importing-from-3ds-max.html

@Delighte: thanks a lot ! I will test with Maya tonight ! It should work for sure ! Thanks for the thread with the error , it was made in front my computer to export again and again and have nothing exported … thx :wink:

it worked by exporting the fbx with maya ! Thanks a lot to @Delighte !