Importing Skeletal Mesh into UE4 from the ART tool

I need help importing skeletal meshes into UE4. I have followed countless tutorials and have read all documentation that I could, but I have yet to find out what I am doing wrong. I am hoping that I am just being silly and missing a very simple check box somewhere, but I am not sure anymore. My question is…

What is the correct workflow to import a Mixamo character mesh into UE4 with a custom rig?

Here is what I am doing:

Using the ART (animation and rigging toolkit) tool, I am creating a rig for one of the free Mixamo characters (plain human). I am deleting the skeleton it comes with when you download the FBX and only using the mesh. Following the tutorials online, I skin the joints and build the control rig. Then I import the rig into UE4. I select the root bone and then the mesh, and export using the recommended settings in the documentation. After I import the FBX into UE4 and open up the skeleton, the joints of the skeleton are NOT listed. The only bone shown is the root bone.

I have also tried NOT deleting the mixamo skeleton and parent-constrain it to the rig created by the ART tool (since as far as I know, the tool does not work with pre-made skeletons). I still run into the same issue where only one bone is shown.

I should also mention that I do not receive any warnings or errors.

I am using Maya 2014 and UE 4.5.1

Any help would be greatly appreciated!:slight_smile:

Whenever I export skeletal meshes from Maya/ART into UE4, I just select the mesh and use Export Selected. I don’t even bother selecting the skeleton. If that doesn’t work, maybe you could show me some pictures of your process? Particularly, export/import options you are using and what you have selected when you are exporting. There is definitely a learning curve on getting all the Maya/ART/UE4 stuff right, so I can relate with the heartache lol

Tell me about it! Hopefully I am just missing something very simple and then I will feel stupid about it later.

Unfortunately, I need the skeleton to be imported as well. I have also tried importing a mesh straight from the ART tool (no real adjustments), and although it imports fine in unreal, I am missing the hierarchy of all of the bones. Meaning all the joints are on the root.

That’s what I’m saying; whenever I import skeletal meshes, I just select the mesh for export selected and it brings everything into ue4 as a full skeletal mesh, including the current animation if I want it.

Let’s see… in the export, try going to Animation, then Constraints, then checking Skeleton Definitions.

If neither of these work I might need some more details.

It is still not working for me, unfortunately.

I believe it might have something to do with unreal since my colleague just copied my process on his computer and it works as expected. I am very new to UE4, so maybe I am missing a very obvious answer?

At this point, all I am doing is just creating a generic character with the art tool, exporting it with the skeleton (I tried your way as well), and importing it in unreal. I get the bones in there, but they are not in a hierarchy, and are all at the root’s location…

That definitely sounds like a Maya problem. Wanna take me through your entire ART process? It seems like the problem is in how you’re setting up the skeleton.

FINALLY GOT IT WORKING! I have no idea why, but my process was not working with Maya 2014. I tried the same thing in Maya 2013 and it worked as expected. But I am still really confused as to why this is happening. Here is exactly what I am doing:

  1. Open Maya 2014
  2. Epic Games / Character rig Creator
  3. Skeleton Placement (I am not editing anything)
  4. Click “yes” to *Are you sure you want to build the skeleton with your chosen parameters?"
  5. Deformation Setup (again not changing anything) - on pop up windows: create rig pose / yes / save rig pose / yes
  6. Highlight both root and mesh in outlier (Proxy_Geo_Skin_Grp)
  7. Export selected (FBX settings are exactly as the picture provided above except under geometry, I only have “Smoothing Groups” checked)
  8. I get two warnings (these should be fine though)

-----Warning: Constraints export failed
-----Warning: The FBX plug-in does not support assets created with the Advanced Asset menu. (1)

The same errors can be seen here:

  1. In UE4: import FBX file. Settings are shown on picture above.
  2. Open Skeleton

It still looks like it’s grouping them all under root instead the proper hierarchy. Are you still experiencing that problem? While it may not seem important now, you’d run into major problems later when trying to blend animations per bone, with an example being using an upper body wave animation while maintaining a lower body walk animation, with the bone blend using something like spine 3 as the hierarchy divider.

But maybe… I’m just seeing this picture wrong? Let me know, unless you are sure that you will not be using blended animations and therefore don’t really care lol

I am sorry for the confusion!

My last comment and picture are both based on my process in Maya 2014, which is still an issue.

Using the same exact process in Maya 2013 works correctly. The skeleton imports to UE4 correctly and maintains the bone hierarchy (I will most likely be using blending yes).

Until I can figure out what is wrong in 2014, I will be using 2013, unfortunately. Such a weird problem =/

Hmmm, I am having what appears to be the identical issue, but using Maya 2015. Did you ever figure this out?

Hello AMT,

Yes! Here is the tread on the forums. Jeremy Ernst helped me figure this out thankfully!

Here is the video that explained what I was doing wrong.


Solution → Make sure to have deformed models turned on under animation in the FBX settings when exporting from Maya 2015!

Let me know if you need any help. :slight_smile: