Download

Importing any PNG with alpha channel messes up the image

Whenever I try and import a PNG with alpha channel, it messes up the alpha parts of the image and the whole texture is unusable in the editor (stretches all over the place and distorts).
I’ve already tried different versions of PNG compression etc. and different files alltogether, it’s all the same problem. Even PNG files I downloaded from a UE4 tutorial (image below) don’t import properly.
I’m using UE4.3

TL DR:
Don’t use png. Use .TGA with alpha channel or .PSD

When I import as psd = same problem
When I import as TGA = equally horrible problem
Save file with SuperPNG = same problem
Use layer mask as alpha = same problem

*Edit
Okay now it works. The material editor doesn’t show the transparency, but in game it shows up.
I think it has to do with creating a seperate alpha layer and then importing as psd file, but I have to get into this a bit more.

Thanks for the help!

What compression settings do you use?
TC_Grayscale use only one channel, not four.

It works now.
If anyone else has the same problem, here is the solution:
Go to Photoshop > Layer > Layer Mask > From Transparency
Go to UE4, import the psd file and it works.
editwell now I have another problem

Well, turns out I have the next problem.
When I import a psd that uses this method, the alpha still gets messed up in the engine.
Now it looks like the engine only understands the alpha channel if fully opaque or fully translucent and everything in between is drawn as white.

Are you actually USING the alpha channel? By default it isn’t used. In your material editor you need to connect it (the bottom pin of your 4Vector) to the opacity mask, translucency, etc.

If connected to opacity mask, it has a cutoff point (opaque above, invisible below) you can set. Other modes work differently but you must set the material up to be translucent/etc.

1 Like

Yes, the alpha channel is connected to the opacy.
The texture editor even shows the same white border where there is no white in the entire image. Only black and translucent background.

Uploaded an image to show exactly what I mean.
Photoshop file = no white pixel color information
After importing to UE4 = white border where transparency should be

Your problem is very weird, could you share source image you use and your shader screenshot?

Really I didn’t do anything out of the ordinary. I’ve worked with Photoshop over ten years+ and never had any issue like this before.
Here’s what you do to recreate the problem.
Open Photoshop (I use CS6)
Draw a circle with transparent edges
Background transparent (doesn’t make a difference if you use layered mask for alpha channel)
Save image, import the psd in UE4
Look at the texture import window, enable alpha channel and you see a white border around the circle.

I’ve made fast basic video, maybe you will spot something!

Thank you so very much!
I didn’t understand that you have to EITHER have transparency in the image OR have the alpha channel.
Bless you my friend :smiley:

Holy ■■■■ that helped me so much. Solved a nasty black lines problem i was having thank you thank you.

Please help me I need Grass_N PNG file but I don’t know how to get it