Imported walls letting light in

I don’t know if I’m doing something wrong, but my imported walls from blender keep some lighting inside (I think).
If I build closed room with BSP, it gets completely dark, like I want. When I use imported meshes it get a wierd glow in the corners.

Would appreciate some help with it.

Hi Rbacch,

When you import your mesh, depending on the UV layout for the lightmap you’ll likely need to increase your Lightmap Resolution for the mesh. By default it will use a value of 64, so you may need to adjust the value to something higher like 128 or 256 to get better results, then rebuild lighting and see if that helps.

If you’re still having issues, please post a screen shot of your Lightmap UV (UV Channel 1). You can do this by going to the Static Mesh Editor and hitting the UV button in the toolbar. Then in the drop down next to it, select UV Channel 1.

Thank you!


Thanks for the reply, Tim, and sorry for the delay. I changed the lightmap resolution as you said, but the problem persists. I think the problem are the meshes overlapping each other, since I’m new to 3D modeling and I don’t know about scaling or about anything. lol But since you asked, there’s the UV Channel 0 (made by me on blender) and Channel 1 (auto generated by UE).
About the lightmap, is there a problem, for example, my floor having a resolution of 128 and walls having 256?

Thanks again for the reply.

  1. Make sure there’s no gap where walls should come together.
  2. Check if it also happens if you switch to dynamic lighting and disable lightmaps altogether
  3. When you rebuild your lighting do you get any errors/warning?

Now i got it. For some reason there was a hidden gap that I couldn’t find earlier. Thanks.