Download

Imported Animations too small

When I import a skeletal mesh in a .fbx file with animations when I import the animations they’re too small. How can I fix this?

Make sure the scale is in centimeters instead of meters/inches and make sure transforms are frozen at 1 scale and so on.

I had them in the correct scale, the mesh imports at the right size. Could you give me a list? I had the scale at 1 too, it’s just the animations are screwy.

A list of what? Anyway if your scale was right you wouldn’t have issues so no, it’s not the correct scale. But it’s hard to tell what’s wrong because you didn’t give any information, like what software you’re using, screenshots of the problem and so on.

If you’re using 3ds max make sure that your scene units are set to meters and the fbx export meters are set to centimeters.

I’m using Blender 2.72, I can attach the .fbx if you want. Like I said the rifle is about the right scale but the animations are way too tiny. I will attach the .fbx

You’re using the wrong scene scale, in my scene the rifle was 1.5cm long. To fix it you set the scene unit scale to metric 0.01, then scale the rig up 100 times. After that do Apply Object Transform (with spacebar), ticking Scale in the lower left. Your animations will get messed up, to fix it, select the rig and open the graph editor, there click the magnifying glass and type “location”. Then to the right click the pivot point and change it to 2D cursor. Then select all keyframes and scale by 100, pressing Y to constrain the scale vertically.

Your rifle rig is also offset in the scene which could cause problems, you can fix that by pressing Ctrl+C to set the 3d cursor in center, then selecting the armature and doing Snap Selection to Cursor, Apply Object Transforms ticking Location Rotation, then do the same for the mesh. You may need to reset the location keyframe for the body and insert new keyframes.

Ok. I’ll try these things. Didn’t understand why when it imported as a static mesh the scale was okay but the rig was not.

The UE4 scaling fix when importing works for static meshes but doesn’t work for rigs at the moment.

I finally managed to fix the animation import sizes by setting the blender unit scales to .01 and having the export settings for the .fbx as 100. But now when I click on the animation version it zooms it by I think like kilometers. How do I fix this? Why does it import the animations 1% of what they should be to begin with? Why are the animations always so small, when the static mesh by itself is always the correct scale?

I finally fixed it. Using a blender unit as 1 CM and disabling the size thing the animations and static mesh are imported at the same sizes. Now I just need to fix the offset between the static mesh and animations when importing.

Your mesh is not a static mesh, it’s a skeletal mesh because it’s used together with a skeleton. I told you how to fix the offset above, you need to move everything to the center and apply transforms.

I wanted the offset from the grid center for the objects. You misunderstood me there. But now that I have all this fixed the bones are facing the wrong way imported, despite in Blender they’re facing forward x. How do I fix this?

What’s the wrong way? Normally you would have the rig facing forward in Blender, meaning -Y in Blender. Then you can rotate it in the BP to match the arrow.

This is why Blender is a nuisance to work with…Because it don’t support Unreal World Settings unless the newer versions of it do now. for I think its time for the Blender Developers to implement the settings needed for Unreal Engine in their program…So its more unreal engine friendly… There should be an extra option in Blender under scene settings in Blender - Use Unreal Engine World Settings’

https://youtube.com/watch?v=KDP7GHFtAtEUnreal blender to ue4 essential training livestream.

… What? That’s what scene unit scale is. By default 1 unit is 1m. Changing it to 0.01 means 1 unit is 1cm, which is the same as in UE4.

What I mean by engine friendly, is that some people are not going to know that if they are not familiar with Unreal Engine scaling so when they see ‘Scene Unit Scale’ it should be called Unreal Engine Scale Units or down in the help description when you hover the mouse over the scale unit, also pop up a list of game engines that the scale units supports so then those who are not experienced with Blender or with the game engine they have then know what scale units to use for what game engines that they do have. Now a help system like that on Blender’s import/export settings would certainly make things more easier so then you don’t accidentally select the wrong settings for
your game engine and that should clear some of the confusion once you can see the relationship the game engines have with those settings. I’m sure some of the plugins
for blender for unreal engine have made some effort towards that.

True Blender supports Unreal Unit Scale, but Blender is a little bit different, because the armatures appear enormously big in that program… And there is
an issue in that program (don’t know if its been fixed yet in the latest version) that if you do move the bones of the armature around when you’re in the object mode, it will
shift the bones of the armature in Blender 3d world location space and cause them to move or twist the armature bones out of place, it won’t always show this up on the armature in Blender so you have to check the Rotation, Transform and Scale to see if the numbers have been altered and when the scale rotation bug gets triggered off, the way to fix it is to have to reset the armature again, then and rescale it 100 times up or so… But if the armature is not reset and the infected armature is then exported out then the bug will show up in Unreal Engine in the skeleton editor as stretched or warped twisted bones in the skeleton editor before you even add in the animations or set
up the re-targeting… But if you try to retarget it if the armature was not reset before exporting to Unreal Engine then the animation retargeting will be a warped mess.

Well yeah, you wouldn’t want to export a character that is not in 0/0/0. But you can move it in object mode without anything weird happening. Also I don’t know what you’re talking about regarding the armatures appearing big. They look normal to me.

In the picture it’s flying in the air to show that you can have it somewhere else in 3d space (but you wouldn’t export it this way).

Even though this an old post I found a quick workaround that worked out perfectly for me exporting from blender. It was a lot of trial and error.

In Blender

  1. Have your Armature at a scale of 1: if is too small or big, scale it back to 1 then scale your mesh to match and apply scale only to mesh.
  2. Set your scene scale to 0.1 (Meters)
  3. Export Fbx at 0.01 (This is so the mesh and Armature are the same size in unreal, as the armature was always too small)

In Unreal
4. Import Fbx and change the scaling in the import details to x10

This should make your mesh and Animations the same size. There might need to be some tweaking with the original size of your mesh for how big you want your character.
I noticed the Armature was always the same tiny size no matter the exporting scale, so the idea is to just put the mesh to its size then scale them in unreal.
Hopefully this helps someone.