IMPORTANT BUG:Intel Apollo Lake compatiblity issues

Hello,

There is a serious problem about compatibility between Epic Games Launcher and Intel Apollo-Lake systems.
I bought an Asus E403NA computer in December 2017, it has an Intel Celeron N3350 as CPU, 4 gigabytes of DDR3 RAM and an Intel HD Graphics 500 integrated GPU.

The computer runs on Windows 10 Professionnal (1803 x64), everything is normal and works fine. All my games work properly (they use both OpenGL and DirectX) and I do not have any other problem related to software compatiblity.

The only problem is the Epic Games Launcher, after installation (MSI installer and auto-updater) it does not seems alive. When I click on the desktop shortcut, my mouse cursor spins briefly then stops.
The process appears for 5 seconds then disappear on the task manager (uses around 10MB of memory and sometimes there are some network traffic).

I have made a DXdiag report, a Procmon log and I’ve retrieved the launcher logs.
They have all been uploaded: click here.

TO DEVELOPERS
Please take a look at this problem. Many people have been complaining for over a year and no answer has been given.
I am sure there is a unique problem for all Apollo-Lake computers, maybe a chipset or iGPU driver bug/launcher bug ??

I would just like you investigate on it and tell us what is the problem. Even if it can’t be solved, tell us what is wrong so we can stop trying and trying for nothing.

Thank you!

PLEASE can someone answer seriously ? We are complaining for months about this problem.
Can’t a developer just read this thread please ?

Sounds like this is a dead forum

Ok nice, I’m just happy that someone from the development team has got the message.

Nice, I’m just happy that someone from the development team is aware of the problem.

Hi IDroid27,

I am a developer on the launcher team, I just wanted to let you know I was very impressed with the depth of your investigations.

Following your post we have purchased an Apollo-Lake chip set laptop and had an identical experience to yourself, in that it also didn’t work. We are hoping to find time to investigate this issue as the system should be able to run it.

I am sure you understand that the team has a lot on its plate at the moment so we might not be able to get round to solving the issue for sometime. However rest assured we were interested in this enough to purchase the hardware so we will be investigating this at some point.

Sorry I couldn’t come back to you with a fix.

I have a laptop with a Pentium N4200 and I face the same crash as you do. I have even tried updating the iGPU driver to the 6/5/2018 driver from Intel with no luck

@MrMcBarnabas Someone has found a fix to make Unreal Engine Editor working on our platforms! It seems to be an issue related to OpenSSL.
https://forums.unrealengine.com/unreal-engine/feedback-for-epic/1503637-openssl-error-when-starting-ue4editor
I guess it’s the same “code base” so it might also fix EGL ?

Thanks for bringing this to my attention, I’ll add it to the live issue we have associated with this.

Something new on this issue,did you know how to start the program?

@MrMcBarnabas i have the same problem Intel Pentium N4200…the launcher doesnt open,do you know how to fixes,
for a long time is this problem

Hi Scorpionvm90,

The work around suggested in the post above is only viable for using unreal engine via github. There are no currently known workarounds for this issue using the Epic Games Launcher. The potential fix has been passed to the relevant team for consideration. Unfortunately there is a lot of high priority work going on at the moment so I am unable to give you any time estimate as to when this work will be looked at.

@MrMcBarnabas I hope will be soon … :slight_smile:

half a year has passed. When will the error be resolved?

Any updates on a fix? A user has even pointed out a likely fix.

Its 2019 now, 6 months since the bug report :frowning: A whole class of chips can’t run the launcher.,Its 2019 now, 6 months after the bug report, and 4 months since someone pointed out a potential fix (OpenSSL).

There are a lot of machines being sold with Apollo Lake chips, any updates on a fix?

Can once again create a topic about the problem to the developers?

Hi, @MrMcBarnabas

I have same issue with Apollo Lake N4200, and when I’m preparing to build (A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums), Setup.bat can’t download some files, because file has very long name:

GitHub\UnrealEngine>Setup.bat
Checking dependencies (excluding Mac, Android, Linux)…
Updating dependencies: 99% (34172/34200), 5855.2/5855.9 MiB | 1.51 MiB/s…
Failed to download ‘http://cdn.unrealengine.com/dependencies/UnrealEngine-4358751-16521f530c414728b289dbb71f593410/80c1ba699c3de9b0950a5521e587025e7f85f8bb’: Слишком длинный путь или имя файла. Полное имя файла должно содержать меньше 260 знаков, а имя каталога - меньше 248 знаков. (PathTooLongException)
Для продолжения нажмите любую клавишу . . .

Help me, please, where I’m wrong?

Still nothing on this issue???

Hello! Half a year passed and still we have a problem?When the problem will be resolved,this is unreasonable…

Hello! Half a year passed and still we have a problem?When the problem will be resolved,this is unreasonable…

Hi All,

Thank you for your patience. Just to bring you up to speed. There is movement on this issue. The fix has been introduced into epics main codebase. The launcher team will be scheduling in a period to take the latest changes from the main codebase but this is a time consuming process during a period when the team is extremely busy.

The tentative goal currently is to have this completed by the end of Q2. However please understand that priorities shift quicker at epic then ever before.