Import FBX: Material IDs incorrect?

Im made screenshots that show the problem better than me trying to explain it. Basically I’m trying to import a static mesh with two materials on it. I assigned the material IDs in 3DS Max but they seem to make it over to UE4 only partially correct. I am using the workflow as described in the [UE4 docs][1], creating a MultiSub-Object.

What am I missing?

EDIT: After remodeling the mesh, the problem fixed itself. Still not sure what caused it in the first place though.

EDIT 2: It seems that manually triangulating the poly before exporting the fbx, fixes the problem. So maybe the automatic triangulation messes things up somehow.

Hi, I have found a workaround:

  1. Create a new object, anything, a box or a sphere.
  2. Convert the new object to Editable Poly.
  3. In the new object, click Attach and select the mesh with ID problems.
  4. Select by Element and delete the new object.
  5. You will need to fix your pivot and probably Reset the Xform of your mesh.
  6. Export!

I hope it works for you too.

1 Like

Yes! your workaround did the trick. haha, I was banging my head on the desk trying to figure out what was wrong. Thanks, Cheers!

oh god! what a life saver… This fixed the same problem for me as well.

Thank you so much! I was going crazy here! It worked.