Download

I need help with Global illumination

I have activated GI, and now I have “Preview” writing everywhere that I can’t get rid of. (GI doesn’t build lighting)
Also it has randomly made some walls really bright, and others dark.

Does anyone know how to fix this? Have I accidentally ticked a setting that makes it like this?

Thanks.

Also all my window snow do this:

How exactly did you enable GI? Only Lightmass gives GI and you need to build the lights in order to get rid of those preview overlays, and all your meshes need proper lightmap UV’s.

I added “r.LightPropagationVolume=1” to consolevariables.ini in the 4.1 directory.

And then in the engine, you click on your directional light and enable “affect dynamic indirect lighting”

The only lights I have in the level is the directional light.

All my meshes are properly light mapped and are set to 128 in engine.

- YouTube Here’s the video that shows it

Watch that video, his “preview” text turned off when he made the light moveable. Did you do that?

Preview in the shadows means you’re using a static light somewhere.

That worked, thank you :slight_smile:

You need to enable “Force No Precomputed Lighting” in World Properties.

Not completely true.

You can enable Precomputed Lighting as if you disable it, reflection captures won’t work.

In the video, I use a mixture of precomputed lighting and light propagation volumes.
I would post my settings here but unfortunately, I deleted my project file.

iPlay_Zombies, get settings from here:

and the Cornell Box.

Mix and play around with the settings until you get the effect you desire.