I can't see the real-time changes of a material instance

Does anyone know why I can’t see the real-time changes of a material instance?

The cube on the right has the material instance assigned.

I was reading this post but I think the hardware is not my problem:

2 x (Xeon E5-2680V4) (24 Cores) 2.4GHz
GTX 1070 8GB (Driver → 526.47) ( 31.015.2647 → 10/25/2022)

Thanks a lot for your help!!

I had the same problem with UE5, in my case it was even worse: actors were disappearing from the world until I restarted my editor (or changed the map).
I solved it clicking Verify on my engine version, I don’t know if it’s your case but it’s worth trying.

It doesn’t work for me…
But I want to thank you anyway!! :sparkling_heart:

1 Like

I found that the problem is the material itself…

I made another instance of a simple test material (just change color) and it works perfectly.

However, I have not been able to find out what the problem is that exists in the original material.

This is the material code:

And the details:

Do you know what could be the problem?

thx u so much!!

Where did you get this material from? Is it from a tutorial?
I tried to replicate it and I have the same error in UE 4.27 (So it’s not an Engine issue)

1 Like


I’m trying to do this effect… it is so cool!!

But the material is explained in this other tutorial (Minute 5:31)

Yes, now I know that the motor works correctly… But I do not find that it is failing in the material… Even applying the material directly to the actor nothing happens… :frowning:

Look at this
I think it’s a coordinate problem.
Inside the actor the cube disintegrates around an invisible sphere that is at the point 0,0,0
I think the world is the same… the invisible sphere that is at the point 0,0,0 of the world.
But the cube is too far away (wherever) and that’s why it doesn’t disintegrate…
At least that’s my theory :slight_smile:
I still haven’t solved the problem… I hope that’s it

Yes, in the end it was a problem of coordinates… The material seemed not to work because the sphere was at the origin of the world and the cube was too far from the radius of action of the sphere.

Thank you very much for your effort to help me Ares. Very appreciated!! :sparkling_heart:

1 Like